This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 697364 - RFE -- allow for customized document templates
RFE -- allow for customized document templates
Status: CLOSED DEFERRED
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-17 23:21 EDT by Ruediger Landmann
Modified: 2014-05-22 02:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-22 02:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2011-04-17 23:21:52 EDT
Publican has a limited number of document templates for use with the "create --type" option (set, article, book). It would be useful to allow users to specify (and perhaps ship?) extra templates, such as "create --type ieee_test_plan"
Comment 1 Stephen Gordon 2011-04-17 23:32:10 EDT
To +1 this I would be interested in having a 'man' template included to facilitate faster creation of manual pages in DocBook XML.
Comment 2 Ruediger Landmann 2011-04-18 01:09:31 EDT
(In reply to comment #1)
> To +1 this I would be interested in having a 'man' template included to
> facilitate faster creation of manual pages in DocBook XML.

Since we support 'man' as an output format, this might be better added to Publican itself?
Comment 3 Jeff Fearn 2011-04-18 18:45:24 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > To +1 this I would be interested in having a 'man' template included to
> > facilitate faster creation of manual pages in DocBook XML.
> 
> Since we support 'man' as an output format, this might be better added to
> Publican itself?

This bug is about adding template functionality, we won't be supplying any specific templates as part of this bug.
Comment 4 Jeff Fearn 2014-05-22 01:51:36 EDT
(In reply to Stephen Gordon from comment #1)
> To +1 this I would be interested in having a 'man' template included to
> facilitate faster creation of manual pages in DocBook XML.

If you can specify what the template would look like (docbook wise) please open a separate bug for it.

Note You need to log in before you can comment on or make changes to this bug.