Bug 69764 - reports packages are already downloaded, then spins.
reports packages are already downloaded, then spins.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 01:04 EDT by Need Real Name
Modified: 2015-01-07 18:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-25 01:04:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020508
Netscape6/6.2.3

Description of problem:

unlike bug 69656, i observe no disk activity, no progress.  i have repeatedly
tried upgrading the kernel packages, results appear to always be the same. 
reports that all packages are already downloaded, then spins.  (all packages
except the 2.4.18-5.73 src that gives a 404 error.)  session output follows.

02-07-24
19:42:30 [377] bubo6:redhat/rhn-packages# up2date

** (up2date:22845): WARNING **: could not find handler `onRegPackagePageBack'
/usr/share/rhn/up2date_client/gui.py:260: DeprecationWarning: use
GdkColormap.alloc_color
  color = self.druid.get_colormap().alloc(52232, 0, 0)
error: failed to stat /mnt/b7k: Input/output error
/usr/share/rhn/up2date_client/gui.py:1414: DeprecationWarning:
  totalProgress.update(0)
/usr/share/rhn/up2date_client/gui.py:1377: DeprecationWarning:
  self.progress.update(i)
<ProtocolError for www.rhns.redhat.com
/XMLRPC/$RHN/redhat-beta-limbo-i386/getPackageSource/kernel-2.4.18-5.73.src.rpm:
404 Not Found>
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1437, in doRetrieval
    self.setRetrievalProgress)
  File "/usr/share/rhn/up2date_client/up2date.py", line 284, in getPackage
    progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 151, in doCall
    (errCode, errMsg ) = rhnHTTPlib.reportError(e.headers)
  File "/usr/share/rhn/up2date_client/rhnHTTPlib.py", line 333, in reportError
    _sList = headers.getHeaderValues(s)
AttributeError: Message instance has no attribute 'getHeaderValues'

** (up2date:22845): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
02-07-24
19:50:53 [379] bubo6:redhat/rhn-packages#

02-07-24
19:52:19 [383] bubo6:redhat/rhn-packages# rpm -qa | egrep 'up2d|rhn'
up2date-gnome-2.9.20-7.x.9
up2date-2.9.20-7.x.9
rhnlib-0.8-11
02-07-24
19:52:40 [384] bubo6:redhat/rhn-packages#



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.up2date
2.select all kernel packages
3.
	

Actual Results:  as shown in the description section.

Expected Results:  successful updates.

Additional info:
Comment 1 Adrian Likins 2002-07-25 19:06:28 EDT
some of the stuff you mention has alreadty been fixed.

the "AttributeError: Message instance has no attribute 'getHeaderValues'"
has been fixed (2.9.25 or so...). But it is a code path that
indicates your session has timeout and you need to reauthenticate
(in the bugfixed versions, this happens transparently). But
it sounds like your not finishing downloading all the packages
and the gui is just hopping to the next screen which claims
everything is downloaded. Should be fixed

the "error: failed to stat /mnt/b7k: Input/output error"
concerns me somewhat...
Comment 2 Todd Warner 2004-08-26 20:06:38 EDT
RHL 8.0 is not supported anymore.
But... seems to be fixed. This is a "keep and eye out for it" bug for
current versions.

Note You need to log in before you can comment on or make changes to this bug.