This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 69768 - possible problem with fdisk / disk druid. partition info wrong
possible problem with fdisk / disk druid. partition info wrong
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 02:17 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 00:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-25 02:17:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
i have installed Redhat linux 7.3(valhalla) along with windows 2000 on
my machine. The install goes on smoothly. I partitioned using disk
druid to allot 4gb to linux and 256 mb as swap( i have 128 mb ram) .

There is no problem when i am in linux. but when i change over to
windows 2000 i get message "drive H" (ie my linux partition) which windows 
claims to be marked as FAT32 does
not appear to be a windows 2000 drive. and then it automatically skips
check.

I reinstalled linux once again  after deleting the partitions i created using 
disk druid and tried with fdisk. The results were same.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Multiboot install of redhat 7.3 and windows 2000 professional with grub as 
boot loader
2.use disk druid /fdisk of installer to create linux native and swap partition. 
linux partition was formated as ext3
3.Install linux and restart to windows 2000
	

Actual Results:  There is no problem when i am in linux. but when i change over 
to
windows 2000 i get message drive H (ie my linux partition) FAT32 does
not appear to be a windows 2000 drive. and then it automatically skips
check.



Expected Results:  The drive H should not have even showd up in windows 2000 as 
its a linux partition.

Additional info:

The linux partitions were marked with the proper
partition type for their format. here is what fdisk gives me 


/dev/hda1  *  1 578       4642753+    b    win95 FAT 32 
/dev/hda2     579 2491    15366172+   f    win95 Ext'd(LBA)
/dev/hda5     579 1181    4843566     83   Linux
/dev/hda6     1182 1244   265041      82   Linux Swap
/dev/hda7      1215 1853  5132736     7    HPFS/NTFS
/dev/hda8     1854 2491   5124703+    b    win95 FAT32


Note: i got the problem rectified by deleting the linux native and swap 
partition and recreating and formating the linux native( as ext2) and linux 
swap using the Partition Magic (PQ MAgic) tool. I reinstalled redhat and dint 
not ask the installer to format the partitions i had created using PQ Magic. 
Now i have no problems in win 2000
Comment 1 Michael Fulbright 2002-08-02 14:50:27 EDT
Any ideas Matt?
Comment 2 Matt Wilson 2003-02-05 22:51:53 EST
I have no idea what could have caused this.
Comment 3 Jeremy Katz 2003-07-09 00:55:50 EDT
Unable to reproduce here.  If you can reproduce with current code, please reopen.

Note You need to log in before you can comment on or make changes to this bug.