Bug 69801 - panel doesn't start, FAM errors
panel doesn't start, FAM errors
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-vfs2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 11:24 EDT by ellson
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 18:43:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ellson 2002-07-25 11:24:10 EDT
Description of Problem:
gnome-panel isn't starting automatically on my system. 

When I start gnome-panel from a terminal, I get the errors in Actual results
below, but the panel starts OK

If I kill the panel from the terminal, it restarts itself as a detached process OK.

Version-Release number of selected component (if applicable):
gnome-panel-2.0.2.90-4
rawhide-release-20020724-1

How Reproducible:
100%

Steps to Reproduce:
1. run "gnome-panel" from a terminal
2. 
3. 

Actual Results:
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
No object_type set for panel object with ID 00000001
No object_type set for panel object with ID 00000002


Expected Results:
No errors.
Start automatically at login.

Additional Information:
Comment 1 ellson 2002-07-25 11:34:32 EDT
Checking "save current setup" on logout solves the
problem with the panel not starting, but the FAM errors are still present.

Test procedure is:
    $ for i in [a-z];do killall gnome-panel;done
    $ gnome-panel

Comment 2 Havoc Pennington 2002-07-25 12:15:59 EDT
I think there's something weird/hosed about your system to cause those FAM errors.
May also be causing the panel issue.
Comment 3 ellson 2002-07-25 12:28:18 EDT
I agree, but where do I look for the cause of FAM errors?

Its probably a stuck file somewhere in the system from some previous broken
install, but what is it and why hasn't it been cleared by recent updates.

I've removed every $HOME/.* file that looked relevant, and also all
/var/tmp/* and /tmp/* files owned by me, but I still get the errors.
Comment 4 ellson 2002-07-25 12:40:42 EDT
On a different system, also updated to Raw Hide 20020724, I also get errors
from gnome-panel, but they are different:

ellson@amber:ellson> gnome-panel
Unable to open desktop file applications:///Internet/mozilla.desktop for panel
launcher: Error reading file 'applications:///Internet/mozilla.desktop': File
not found
Unable to open desktop file applications:///Office/redhat-word-processor.desktop
for panel launcher: Error reading file
'applications:///Office/redhat-word-processor.desktop': File not found
Unable to open desktop file applications:///Office/redhat-presentations.desktop
for panel launcher: Error reading file
'applications:///Office/redhat-presentations.desktop': File not found
Unable to open desktop file applications:///Office/redhat-spreadsheet.desktop
for panel launcher: Error reading file
'applications:///Office/redhat-spreadsheet.desktop': File not found


Also I get an error popup window with:
There was a problem loading applet 'OAFIID:GNOME_SystemTrayApplet'

Details: g_module_open of `/usr/lib/libsystem-tray-applet.so' failed with
`/usr/lib/libsystem-tray-applet.so: cannot open shared object file: No such file
or directory'
Comment 5 Havoc Pennington 2002-07-25 14:19:54 EDT
Those errors are all unrelated and should go away with latest mozilla,
openoffice, gnome-panel (not sure these are pushed to rawhide yet).
Comment 6 Alexander Larsson 2002-08-07 05:21:08 EDT
I think the FAMOpen Failed message is from gnome-vfs. I've seen it when fam was
screwed up.
Comment 7 Havoc Pennington 2003-01-07 18:43:27 EST
I haven't seen other reports of this, but if it's still happening we should 
probably move the bug upstream and see if they have.

Note You need to log in before you can comment on or make changes to this bug.