Bug 698055 - Task: Set up gitzilla for zanata
Task: Set up gitzilla for zanata
Status: CLOSED WONTFIX
Product: Zanata
Classification: Community
Component: Maintainability (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Sean Flanigan
Zanata-QA Mailling List
: Task
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 00:02 EDT by Sean Flanigan
Modified: 2015-02-23 19:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-23 19:58:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-04-20 00:02:01 EDT
We should set up gitzilla so that commits which mention rhbz# will automatically add comments in bugzilla.  See http://www.theoldmonk.net/gitzilla/
Comment 1 Sean Flanigan 2011-04-20 03:32:31 EDT
Due to a number of dependencies, but especially Python 2.5+, gitzilla won't build or install on RHEL 5.  

I managed to install it on RHEL 6 by rebuilding pcarrier's pybugz rpm for F13 and then installing gitzilla from source (sudo python setup.py install), but it appears that pybugz silently fails when running against Red Hat Bugzilla.  (You can see this by using the 'bugz' command-line tool and trying to add a comment.)

We might need to extend gitzilla so that it can use the library python-bugzilla instead of pybugz.
Comment 2 Michelle Kim 2012-11-12 20:07:56 EST
Hi Sean, Is this task still valid?

Note You need to log in before you can comment on or make changes to this bug.