Bug 69815 - scrollkeeper should conflict with packages that have invalid omf files
scrollkeeper should conflict with packages that have invalid omf files
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: scrollkeeper (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
: 70161 70163 70164 70176 70179 70180 74194 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-25 13:40 EDT by Jay Turner
Modified: 2015-01-07 18:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-16 11:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2002-07-25 13:40:06 EDT
Description of Problem:
Getting the following on a 7.3 -> Milan-re0725.nightly upgrade:

Upgrading file-roller-1.107-1.
OMF file [/usr/share/omf/gnome-user-docs/gnome-users-guide-C.omf] does not
validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register /usr/share/omf/gnome-user-docs/gnome-users-guide-C.omf
OMF file [/usr/share/omf/gnome-user-docs/glossary-C.omf] does not validate
against ScrollKeeper-OMF DTD: /usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd

And it goes on and on for some time.  As a side note, I'm getting the same
messages on upgrades of the following packages:
- gnome-games
- gnome-applets
- gdm
- galeon

but I'm not going to log bugs against those, as I suspect that it's the same thing.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Havoc Pennington 2002-07-25 14:28:33 EDT
Well, this is close to unfixable. When you install these packages they run
scrollkeeper-update. 7.3 has a bunch of invalid scrollkeeper files. There's no
way to install all the packages with fixed scrollkeeper files, before any
packages that run scrollkeeper-update.
Comment 2 Jay Turner 2002-07-25 14:36:40 EDT
Very interesting.  Guess that we'll just make note in the release notes about this.
Comment 3 Jeremy Katz 2002-07-25 15:26:12 EDT
You could add a Conflicts to scrollkeeper for the older versions of the packages.
Comment 4 Havoc Pennington 2002-07-31 17:21:33 EDT
Packages scrollkeeper should conflict with:
 - nautilus
 - gnome-user-guide
 - galeon
 - glade
 - ggv
Comment 5 Havoc Pennington 2002-07-31 17:22:08 EDT
*** Bug 70161 has been marked as a duplicate of this bug. ***
Comment 6 Havoc Pennington 2002-07-31 17:22:40 EDT
*** Bug 70163 has been marked as a duplicate of this bug. ***
Comment 7 Havoc Pennington 2002-07-31 17:23:08 EDT
*** Bug 70164 has been marked as a duplicate of this bug. ***
Comment 8 Havoc Pennington 2002-07-31 17:23:34 EDT
*** Bug 70180 has been marked as a duplicate of this bug. ***
Comment 9 Havoc Pennington 2002-07-31 22:26:46 EDT
*** Bug 70163 has been marked as a duplicate of this bug. ***
Comment 10 Havoc Pennington 2002-07-31 22:27:51 EDT
should also conflict with evolution
Comment 11 Havoc Pennington 2002-07-31 22:33:45 EDT
*** Bug 70161 has been marked as a duplicate of this bug. ***
Comment 12 Havoc Pennington 2002-07-31 22:43:51 EDT
*** Bug 70161 has been marked as a duplicate of this bug. ***
Comment 13 Havoc Pennington 2002-07-31 22:57:49 EDT
*** Bug 70179 has been marked as a duplicate of this bug. ***
Comment 14 Havoc Pennington 2002-07-31 23:06:53 EDT
*** Bug 70176 has been marked as a duplicate of this bug. ***
Comment 15 Havoc Pennington 2002-08-07 22:08:41 EDT
scrollkeeper 0.3.10-4 should conflict with these packages and thus avoid the
warnings.
Comment 16 Jay Turner 2002-08-16 00:14:01 EDT
scrollkeeper-0.3.10-5 has the following conflicts:
nautilus < 2.0.3
gnome-user-docs < 1.93
galeon < 1.2.5
glade < 0.6.4-6
ggv < 1.99.9
evolution < 1.0.8
Comment 17 Mike McLean 2002-08-16 11:22:54 EDT
With scrollkeeper scrollkeeper-0.3.10-5, I still see omf errors in upgrade.log
with several packages, with both 7.2 and 7.3 upgrades:

Upgrading file-roller-2.0.0-1.
OMF file ...
Upgrading gnome-media-2.0.0-5.
OMF file ...
Upgrading gnome-user-docs-2.0.0-1.
scrollkeeper-update: warning:
/usr/share/omf/gnome-user-docs/introduction-to-gnome-C.omf overrides
/usr/share/omf/gnome2-user-docs/introduction-to-gnome-C.omf
OMF file ...
Upgrading gnome-applets-2.0.1-3.
OMF file ...
Upgrading gedit-2.0.2-3.
OMF file ...
Upgrading nautilus-2.0.4-2.
OMF file ...
Upgrading gdm-2.4.0.7-2.
OMF file ...
Upgrading gnome-games-2.0.3-2.
OMF file ...
Upgrading galeon-1.2.5-6.
OMF file ...
Upgrading ggv-1.99.9-4.
OMF file ...

Looking at the upgrade.log, I see that scrollkeeper-0.3.10-5 is being installed
*before* these packages despite the conflicts:
# egrep 'Upgrading (scrollkeeper|nautilus|gnome-user-docs|glade|ggv|evolution)'
01-RH-everything-upgrade_from_7.2-english-http-GUI.i386/results/upgrade.log 
Upgrading scrollkeeper-0.3.10-5.
Upgrading gnome-user-docs-2.0.0-1.
Upgrading nautilus-2.0.4-2.
Upgrading ggv-1.99.9-4.
Upgrading glade-0.6.4-6.
$ rpm -qp scrollkeeper-0.3.10-5.i386.rpm --conflicts
nautilus < 2.0.3
gnome-user-docs < 1.93
galeon < 1.2.5
glade < 0.6.4-6
ggv < 1.99.9
evolution < 1.0.8
Comment 18 Havoc Pennington 2002-08-16 11:54:07 EDT
I'm not sure what to do then, other than move the bug to installer... Jeremy?
Comment 19 Jeremy Katz 2002-08-20 23:59:11 EDT
This is just going to be one of those things we can't fix on an upgrade. 
Unfortunate, but that's the way the world works.
Comment 20 Havoc Pennington 2002-09-17 13:54:17 EDT
*** Bug 74194 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.