Bug 69816 - up2date bombs out
Summary: up2date bombs out
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-25 18:09 UTC by Need Real Name
Modified: 2015-01-07 23:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 08:16:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-25 18:09:41 UTC
Description of Problem:

Up2date and rhn_register bombs out when executed.


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Log in as root
2. open terminal 
3. launch up2date

Actual Results:

File "/usr/sbin/up2date", line 15, in ?
    from up2date_client import up2date
  File "/usr/share/rhn/up2date_client/up2date.py", line 20, in ?
    import cgiwrap
ImportError: No module named cgiwrap


Expected Results:

launching of up2date 


Additional Information:

Comment 1 Mihai Ibanescu 2002-07-25 18:17:16 UTC
You may want to specify some more information about the version of the
incriminating packages you are running. Please get the latest up2date and rhnlib
packages from:

ftp://people.redhat.com/misa/fixes

and let us know how it turned out.

Comment 2 Adrian Likins 2002-07-25 23:20:04 UTC
Looks like an old version. None of the current versions use cgiwrap
any longer.



Comment 3 cbagwell 2002-07-29 03:02:59 UTC
I also have this same message when running up2date.  I upgraded from RedHat 7.3
to Limbo and I got this message after a successful and event free install.

A "rpm -q -f /usr/sbin/up2date outputs

up2date-2.7.86-7.x.3

I notice the CD-ROM shows 2.9.13-7.x.9 as what have should bave been upraded.

Looking at /root/upgrade.log shows that it was left out of packages to upgrade.

The only extra thing I can think that may be of interest is this.  When I was
upgrading, I selected the custom upgrade box (for no good reason).  I then just
used the boxes that were auto check-marked for the upgrade.  Perhaps this
confused it?

Comment 4 Michael Young 2002-07-29 08:16:27 UTC
Upgrading to limbo1 is known to miss packages (bug 68255), the next beta should
fix this problem.

Comment 5 Adrian Likins 2002-08-08 21:02:45 UTC
looks to have been an update issue


Note You need to log in before you can comment on or make changes to this bug.