This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 698434 - p2 UI-installed plugins not added to installation
p2 UI-installed plugins not added to installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Chris Aniszczyk
Fedora Extras Quality Assurance
:
: 693533 701097 701653 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 17:25 EDT by Lane
Modified: 2014-07-25 01:53 EDT (History)
8 users (show)

See Also:
Fixed In Version: eclipse-3.6.2-5.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-30 23:21:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log file (380.31 KB, text/plain)
2011-04-20 18:30 EDT, Lane
no flags Details

  None (edit)
Description Lane 2011-04-20 17:25:25 EDT
Description of problem:

I just upgraded from Fedora 13 to Fedora 15 beta. I installed Eclipse and the Android ADT plugin. I got to the step of setting the path to the android SDK in using the Window->Preferences->Android dialog, but there is no Android option. The plugin doesn't seem to be activating correctly. I tried deleting my .eclipse directory and reinstalling and that did not help. I booted back into F13, deleted my .eclipse directory and went through the ADT installation and it works fine there. F13, of course, is using older (Galelio) version of eclipse.


Version-Release number of selected component (if applicable):

3.6.2-2-fc15.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install android plugin per the instructions at:

http://developer.android.com/sdk/eclipse-adt.html
https://fedoraproject.org/wiki/User:Hpejakle/Android

2. Instructions break at the step to open Window->Preference

3.
  
Actual results:

No Android ADT plugin love in eclipse.


Expected results:


Additional info:

The only thing I found through google searches was that someone solved this problem by deleting their .eclipse directory and reinstalling everything. That did not work for me.
Comment 1 Severin Gehwolf 2011-04-20 17:57:16 EDT
Could you do what is described in comment 45 by Chris and attach output? Thanks!

https://bugzilla.redhat.com/show_bug.cgi?id=665249#c45
Comment 2 Severin Gehwolf 2011-04-20 18:01:19 EDT
Also, do you have eclipse-pde installed? If not, installing it may solve your problem. However, before you do that please provide the info as I request in comment 1. This output may allow us to debug this further. Thanks!
Comment 3 Lane 2011-04-20 18:12:55 EDT
I did a Live CD install and then a 'yum install eclipse'. It appears I do have the eclipse-pde package installed:

$ rpm -qa | grep eclipse
eclipse-platform-3.6.2-2.fc15.x86_64
icu4j-eclipse-4.2.1-2.fc15.x86_64
eclipse-rcp-3.6.2-2.fc15.x86_64
eclipse-pde-3.6.2-2.fc15.x86_64
eclipse-swt-3.6.2-2.fc15.x86_64
tomcat5-jasper-eclipse-5.5.31-3.fc15.noarch
eclipse-jdt-3.6.2-2.fc15.x86_64

I'll collect the debug information shortly and post it next.
Comment 4 Lane 2011-04-20 18:30:23 EDT
Created attachment 493651 [details]
Log file

Here is the requested log output. I first removed my .eclipse directory. Then I launched eclipse as requested. Then I installed the Android ADT plugin. It then restarted. The attached is a log of the complete process. The plugin is still not working.
Comment 5 Andrew Overholt 2011-04-27 08:07:46 EDT
*** Bug 693533 has been marked as a duplicate of this bug. ***
Comment 6 Andrew Overholt 2011-04-27 08:09:26 EDT
Renaming for clarity.
Comment 7 Fedora Update System 2011-04-27 17:51:46 EDT
eclipse-3.6.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/eclipse-3.6.2-5.fc15
Comment 8 Fedora Update System 2011-04-27 17:52:24 EDT
sat4j-2.3.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/sat4j-2.3.0-2.fc15
Comment 9 Fedora Update System 2011-04-28 10:38:36 EDT
eclipse-3.6.2-5.fc15,sat4j-2.3.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/eclipse-3.6.2-5.fc15,sat4j-2.3.0-2.fc15
Comment 10 Fedora Update System 2011-04-28 15:01:29 EDT
Package eclipse-3.6.2-5.fc15, sat4j-2.3.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-3.6.2-5.fc15 sat4j-2.3.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/eclipse-3.6.2-5.fc15,sat4j-2.3.0-2.fc15
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-04-30 23:21:03 EDT
eclipse-3.6.2-5.fc15, sat4j-2.3.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Andrew Overholt 2011-05-01 17:55:21 EDT
*** Bug 701097 has been marked as a duplicate of this bug. ***
Comment 13 Severin Gehwolf 2011-05-03 10:05:59 EDT
*** Bug 701653 has been marked as a duplicate of this bug. ***
Comment 14 ywcai 2011-05-05 19:04:50 EDT
*** Bug 701653 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.