Bug 698635 - traceroute -- connect: Invalid argument
traceroute -- connect: Invalid argument
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: traceroute (Show other bugs)
5.7
All Linux
high Severity high
: rc
: ---
Assigned To: Jan Synacek
Milos Malik
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 08:51 EDT by Milos Malik
Modified: 2013-04-12 16:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 08:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[Patch] Fix TOS for IPv6 (1.92 KB, patch)
2012-08-06 07:44 EDT, Jan Synacek
no flags Details | Diff

  None (edit)
Description Milos Malik 2011-04-21 08:51:15 EDT
Description of problem:
I believe there is some big/little endian problem. traceroute works as expected on ppc64 and s390x machines.

Version-Release number of selected component (if applicable):
traceroute-2.0.1-6.el5

How reproducible:
always on i386, ia64, x86_64

Steps to Reproduce:
# traceroute -t 4 ::1

Actual results:
traceroute to ::1 (::1), 30 hops max, 40 byte packets
connect: Invalid argument

Expected results:
no errors and similar output as on ppc64 and s390x
Comment 3 RHEL Product and Program Management 2011-05-31 10:10:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-06-11 21:12:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 Jan Synacek 2012-08-06 07:44:37 EDT
Created attachment 602489 [details]
[Patch] Fix TOS for IPv6

This patch was basically all that was fixed in 2.0.13 --> 2.0.14. Backported.
Comment 6 Jan Synacek 2013-03-13 08:10:08 EDT
Red Hat Enterprise Linux 5 has entered Production 2 phase. For more details see https://access.redhat.com/support/policy/updates/errata/. As this bug is not qualified as critical, it is closed as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.