Bug 698840 - Publican glossary links appear not to work
Publican glossary links appear not to work
Status: CLOSED DEFERRED
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 19:31 EDT by Jack Magne
Modified: 2011-05-02 19:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-02 19:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jack Magne 2011-04-21 19:31:04 EDT
Description of problem:

Publican appears to be creating the links to glossary terms, but it is not putting in the anchor IDs.

Version-Release number of selected component (if applicable):

2.7-1

How reproducible:

Always

Steps to Reproduce:
1. Create a document with a gloassary
2. Compile
3. View in Firefox.
  
Actual results:

When clicking on the links referencing other entries in the glossary, the page goes nowhere.

Expected results:

The user should be taken to the requested link.
Comment 2 Jeff Fearn 2011-05-02 19:21:48 EDT
Publican does not support Glossaries at this time due to limitations in translating them.

See https://bugzilla.redhat.com/show_bug.cgi?id=475684
Comment 3 Deon Ballard 2011-05-02 19:37:46 EDT
Jeff,

This is not a feature request. This is a report of a defect. This same bug occurred with FAQs and there could well be other areas where this crops up. I'm reopening.

As for the subject of glossaries in general, not every document is translated. There could be dozens of products even outside Red Hat that could use glossaries. Bug 475684 is still open because using glossaries is a valid request. Microsoft uses glossaries for their product documentation, and we are supposed to use their stylebook as a reference in our docs.

If you don't want to support it *right now* then at least push this bug off into some kind of future bucket, just so this defect doesn't get lost.
Comment 4 Jeff Fearn 2011-05-02 19:50:25 EDT
(In reply to comment #3)
> Jeff,
> 
> This is not a feature request. This is a report of a defect. This same bug
> occurred with FAQs and there could well be other areas where this crops up. I'm
> reopening.

We don't fix issues with the display or use of unsupported tags. FAQs are supported, so the issue was fixed. Glossaries are not supported, therefore the issue will not be addressed.

> As for the subject of glossaries in general, not every document is translated.
> There could be dozens of products even outside Red Hat that could use
> glossaries. Bug 475684 is still open because using glossaries is a valid
> request. Microsoft uses glossaries for their product documentation, and we are
> supposed to use their stylebook as a reference in our docs.

We either support something fully or we don't support it at all. If people want to use unsupported tags then they need to fully support them themselves, which would involve making a brand and doing overriding the XSL.

> If you don't want to support it *right now* then at least push this bug off
> into some kind of future bucket, just so this defect doesn't get lost.

Sure, deferred it is.

Note You need to log in before you can comment on or make changes to this bug.