Bug 698933 - Libvirt floods /var/log/messages with errors
Libvirt floods /var/log/messages with errors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: netcf (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Laine Stump
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 06:33 EDT by Paul Ezvan
Modified: 2016-04-26 13:34 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 12:49:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ezvan 2011-04-22 06:33:12 EDT
Description of problem:

Libvirt is flooding /var/log/messages with errors :

Apr 22 12:26:56 gens libvirtd: 12:26:56.030: 26221: error : interfaceNumOfDefinedInterfaces:229 : erreur interne failed to get number of defined interfaces on host (netcf: unspecified error - errors in loading some config files)

Version-Release number of selected component (if applicable):

libvirt-0.8.8-4.fc15

How reproducible:

Each time libvirtd is started
Comment 1 Stephan Dühr 2011-08-23 03:47:03 EDT
I have this problem with
libvirt-0.8.8-7.fc15.x86_64
netcf-libs-0.1.7-2.fc15.x86_64

The syslog flooding begins when I start virt-manager

looks like opensuse 11.4 had the same problem:
https://bugzilla.novell.com/show_bug.cgi?id=689282
Comment 2 Stephan Dühr 2011-08-23 04:02:40 EDT
I tried this:

[root@t420 ~]# NETCF_DEBUG=true /usr/sbin/libvirtd
warning: augeas initialization had errors
please file a bug with the following lines in the bug report:
/augeas/error
/augeas/error/pathx = "garbage at end of path expression"
/augeas/error/pathx/pos = "/augeas/files/etc/sysconfig/network-scripts/ifcfg-maxspot_|=|(FREE)"
/augeas/load/Modprobe/error = "/augeas/files/etc/sysconfig/network-scripts/ifcfg-maxspot_|=|(FREE)"
/augeas/load/Sysfs/error = "/augeas/files/etc/sysconfig/network-scripts/ifcfg-maxspot_|=|(FREE)"
09:57:31.150: 4665: info : libvirt version: 0.8.8, package: 7.fc15 (Fedora Project, 2011-07-06-15:17:26, x86-17.phx2.fedoraproject.org)
09:57:31.150: 4665: error : interfaceNumOfInterfaces:187 : internal error failed to get number of interfaces on host (netcf: unspecified error - errors in loading some config files)

I was a bit impatient and removed the maxspot connection from NetworkMananger. This fixed it for me.
Comment 3 Fedora Admin XMLRPC Client 2011-09-22 13:52:05 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-09-22 13:55:04 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Adam Stokes 2011-09-23 17:20:34 EDT
(In reply to comment #2)
> I tried this:
> 
> [root@t420 ~]# NETCF_DEBUG=true /usr/sbin/libvirtd
> warning: augeas initialization had errors
> please file a bug with the following lines in the bug report:
> /augeas/error
> /augeas/error/pathx = "garbage at end of path expression"
> /augeas/error/pathx/pos =
> "/augeas/files/etc/sysconfig/network-scripts/ifcfg-maxspot_|=|(FREE)"
> /augeas/load/Modprobe/error =
> "/augeas/files/etc/sysconfig/network-scripts/ifcfg-maxspot_|=|(FREE)"
> /augeas/load/Sysfs/error =
> "/augeas/files/etc/sysconfig/network-scripts/ifcfg-maxspot_|=|(FREE)"
> 09:57:31.150: 4665: info : libvirt version: 0.8.8, package: 7.fc15 (Fedora
> Project, 2011-07-06-15:17:26, x86-17.phx2.fedoraproject.org)
> 09:57:31.150: 4665: error : interfaceNumOfInterfaces:187 : internal error
> failed to get number of interfaces on host (netcf: unspecified error - errors
> in loading some config files)
> 
> I was a bit impatient and removed the maxspot connection from NetworkMananger.
> This fixed it for me.

Fixed for me too on one of my connection instances. Though I think this should go to the augeas team rather than virt team.

Thanks
Comment 6 Laine Stump 2011-10-18 16:47:51 EDT
In these cases it would be useful to attach the contents of the offending ifcfg file to the bug (and initially assign it to netcf; if necessary I can reassign it to augeas).

BTW, there was previously a threading bug in augeas that caused the same netcf error (error in loading some config files) which was fixed in augeas 0.8.1 by this upstream commit:

commit 39ad6cd46357961dda67a1c9eda65229a25858ae
Author: David Lutterkort <lutter@redhat.com>
Date:   Tue Mar 22 17:18:44 2011 -0700

    Eliminate global variable 'comment_depth' in lexer

Since augeas is now at 0.9.0 in Fedora 15, those cases should be long gone.
Comment 7 Christoph Wickert 2012-06-10 07:24:22 EDT
As I wrote in bug 746960 there are no more problems with libvirt, but netcf-0.1.9-2.fc17 (or augeas-0.10.0-3.fc17) still complain:

$ ncftool -d list
warning: augeas initialization had errors
please file a bug with the following lines in the bug report:
/augeas/error
/augeas/error/pathx = "garbage at end of path expression"
/augeas/error/pathx/pos = "/augeas/files/etc/sysconfig/network-scripts/ifcfg-Test|=|!"
/augeas/load/Modprobe/error = "/augeas/files/etc/sysconfig/network-scripts/ifcfg-Test|=|!"
/augeas/load/Sysfs/error = "/augeas/files/etc/sysconfig/network-scripts/ifcfg-Test|=|!"
error: unspecified error
error: errors in loading some config files

It is not the content of the file but it's name that is causing problems. Rename the file to ifcfg-Test and everything is fine. Should we reassign this to augeas then?
Comment 8 Cole Robinson 2012-06-17 11:03:00 EDT
Laine, is this Comment #7 a netcf or augeas lens issue?
Comment 9 Laine Stump 2012-06-17 12:55:16 EDT
I believe it could only be solved by augeas. netcf only supplies a list of globs to match; it is augeas that determines the names of individual files and opens/reads them.
Comment 10 Trever Adams 2012-06-26 07:20:29 EDT
I am seeing this. If a comment (# whatever) shows up anywhere but the beginning of a line I see this.
Comment 11 Cole Robinson 2013-07-02 12:49:54 EDT
On F19 I don't see this, even if there's an embedded comment in an ifcfg file. If anyone can still reproduce, please reopen and attach an offending ifcfg.

Note You need to log in before you can comment on or make changes to this bug.