Bug 698943 - Tomcat failed to start properly or the installer ran out of tries
Tomcat failed to start properly or the installer ran out of tries
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2011-04-22 07:34 EDT by Šimon Lukašík
Modified: 2014-07-04 09:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The catalina.out seems sane (3.63 KB, text/plain)
2011-04-22 07:47 EDT, Šimon Lukašík
no flags Details

  None (edit)
Description Šimon Lukašík 2011-04-22 07:34:51 EDT
Description of problem:
At the end of installation of Satellite 5.4.1 on RHEL6 there is
warning printed regarding the unknown state of tomcat6 start.

    Tomcat failed to start properly or the installer ran
    out of tries. Please check /var/log/tomcat*/catalina.out
    for errors.

We have already had similar reports like this (#205700, #308891,
#653885...). Mostly closed because of missing reproducer. I believe
we have the reproducer today.

Version-Release number of selected component (if applicable):
Satellite-5.4.1-RHEL6-re20110421.0
spacewalk-setup-1.2.6-8.el6sat
tomcat6-6.0.24-26.el6

How reproducible:
- not deterministic, but quite often revealed by the automation


Steps to Reproduce:
1. ./install.pl --disconnected
2. 
3.
  
Actual results:
Warning message is print even thought that tomcat6 was started
properly.

Expected results:
No warning message

Additional info:
Regression against Satellite 5.4.0
Comment 2 Šimon Lukašík 2011-04-22 07:47:18 EDT
Created attachment 494193 [details]
The catalina.out seems sane
Comment 4 Jan Pazdziora 2013-04-15 08:32:04 EDT
Hmmm, tomcat starting in seven seconds is really rare. So yes, the tomcat might have started but is the WebUI really usable?
Comment 5 Šimon Lukašík 2013-04-16 04:15:37 EDT
Jan, it's been awhile, but I have a dim feeling that back then
the WebUI was usable. There was only that non-solicited warning
message.

Note You need to log in before you can comment on or make changes to this bug.