Bug 699065 - scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.14' not found
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.14' not found
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 18:07 EDT by Didier G
Modified: 2011-04-23 23:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-23 23:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vbox-install.log (4.23 KB, text/x-log)
2011-04-22 18:07 EDT, Didier G
no flags Details

  None (edit)
Description Didier G 2011-04-22 18:07:12 EDT
Created attachment 494319 [details]
vbox-install.log

Description of problem:

I run Fedora 14 with 2.6.38 kernel form koji.

Trying to install VirtualBox 4.0.6 build 71344 I get following error 

scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by scripts/basic/fixdep)


Version-Release number of selected component (if applicable):

This problem occurs with both kernel-2.6.38.3-17.fc15.x86_64 and kernel-2.6.38.3-18.fc15.x86_64

I do NOT have any problem with kernel-2.6.38.3-15.rc1.fc15.x86_64 and I can install and run VirtualBox 


How reproducible:

Just try to install VirtualBox with kernel 2.6.38.3-17 or 2.6.38.3-18


Additional info:

I am not alone to have this problem.

See http://forums.virtualbox.org/viewtopic.php?f=1&t=40922&p=184173

Looking at http://koji.fedoraproject.org/koji/packageinfo?packageID=57 and http://www.gnu.org/s/libc/ it seems last version of glibc is 2.13 and there is no 2.14 available.
Comment 1 gene c 2011-04-23 10:20:02 EDT
There is a fix for fedora 14 - instead of using the newer kernel rpm - download the src.rpm and rpmbuild it on fedora 14 - that will use the fedora 14 toolchain.

I tested this and it works fine.

I do not know if this problem exists on fedora 15 or only because of using a f15 built kernel on f14 - hopefully someone can test this.

Really this is NOT a fedora 14 bug - if it is found to be a problem on fedora 15 it should be moved there and not 14.

In the meantime - i think this is NOTABUG.

gene/

Note You need to log in before you can comment on or make changes to this bug.