Bug 699140 - [abrt] gnome-applet-alarm-clock-0.3.1-4.fc15: alarm_applet_notification_show: Process /usr/bin/alarm-clock-applet was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-applet-alarm-clock-0.3.1-4.fc15: alarm_applet_notification_show:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applet-alarm-clock
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f9823202105ff35c77e65169bf0...
: 702527 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-23 13:56 UTC by Bonzo1834
Modified: 2011-05-19 05:06 UTC (History)
2 users (show)

Fixed In Version: gnome-applet-alarm-clock-0.3.2-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 05:06:47 UTC
Type: ---


Attachments (Terms of Use)
File: event_log (11.16 KB, text/plain)
2011-04-23 13:56 UTC, Bonzo1834
no flags Details
File: dsos (21.51 KB, text/plain)
2011-04-23 13:56 UTC, Bonzo1834
no flags Details
File: maps (23.17 KB, text/plain)
2011-04-23 13:56 UTC, Bonzo1834
no flags Details
File: backtrace (15.83 KB, text/plain)
2011-04-23 13:56 UTC, Bonzo1834
no flags Details

Description Bonzo1834 2011-04-23 13:56:42 UTC
abrt version: 2.0.1
comment: start gnome alarm applet, set an alarm and watch it crash
package: gnome-applet-alarm-clock-0.3.1-4.fc15
cmdline: alarm-clock-applet
component: gnome-applet-alarm-clock
executable: /usr/bin/alarm-clock-applet
crash_function: alarm_applet_notification_show
kernel: 2.6.38.2-9.fc15.i686.PAE
time: 1303564800
reason: Process /usr/bin/alarm-clock-applet was killed by signal 11 (SIGSEGV)
architecture: i686
username: pi
uid: 539
rating: 4
os_release: Fedora release 15 (Lovelock)

Text file: event_log, 11427 bytes
Binary file: coredump, 49090560 bytes
Text file: dsos, 22023 bytes
Text file: maps, 23728 bytes
Text file: backtrace, 16214 bytes

environ
-----
XDG_SESSION_ID=3
IMSETTINGS_INTEGRATE_DESKTOP=yes
TERM=dumb
SHELL=/bin/zsh
XDG_SESSION_COOKIE=4035e54f61808e54d547ffd500000010-1303549413.100397-1748287794
GNOME_KEYRING_CONTROL=/tmp/keyring-JFqnci
IMSETTINGS_MODULE=none
USER=pi
USERNAME=pi
DESKTOP_SESSION=gnome
PATH=/usr/local/bin:/usr/bin:/bin:/home/pi/bin:/usr/local/sbin:/usr/sbin:/sbin
QT_IM_MODULE=xim
PWD=/home/pi
XMODIFIERS=@im=none
LANG=en_US.utf8
GNOME_KEYRING_PID=2107
GDM_LANG=en_US.utf8
GDMSESSION=gnome
SHLVL=0
HOME=/home/pi
LOGNAME=pi
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-TG4fmZArQG,guid=ea26d8ef86e582912c7f247500000169
WINDOWPATH=7
DISPLAY=:0
XDG_RUNTIME_DIR=/run/user/pi
XAUTHORITY=/var/run/gdm/auth-for-pi-S4psux/database
OLDPWD=/home/pi
HISTCONTROL=ignoredups
MAIL=/var/spool/mail/pi
HOSTNAME=a1
HISTSIZE=1000
G_BROKEN_FILENAMES=1
'LESSOPEN=||/usr/bin/lesspipe.sh %s'
_=/usr/bin/gnome-session
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2115,unix/unix:/tmp/.ICE-unix/2115
ORBIT_SOCKETDIR=/tmp/orbit-pi
SSH_AUTH_SOCK=/tmp/keyring-JFqnci/ssh
GPG_AGENT_INFO=/tmp/keyring-JFqnci/gpg:0:1
GJS_DEBUG_OUTPUT=stderr
'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/alarm-clock-applet.desktop
GIO_LAUNCHED_DESKTOP_FILE_PID=10815

Comment 1 Bonzo1834 2011-04-23 13:56:44 UTC
Created attachment 494431 [details]
File: event_log

Comment 2 Bonzo1834 2011-04-23 13:56:46 UTC
Created attachment 494432 [details]
File: dsos

Comment 3 Bonzo1834 2011-04-23 13:56:49 UTC
Created attachment 494433 [details]
File: maps

Comment 4 Bonzo1834 2011-04-23 13:56:51 UTC
Created attachment 494434 [details]
File: backtrace

Comment 5 Christoph Wickert 2011-04-23 14:24:55 UTC
Does it crash every time it tries to display an alarm?

Seems related to libnotify 0.7 and I need to look at this closer.

Comment 6 Bonzo1834 2011-04-23 15:06:23 UTC
Yes, the crash is 100% reproducible here on Fedora 15beta with all updates.

Comment 7 Christoph Wickert 2011-05-06 08:04:30 UTC
*** Bug 702527 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-05-06 08:40:45 UTC
gnome-applet-alarm-clock-0.3.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-applet-alarm-clock-0.3.2-1.fc15

Comment 9 Fedora Update System 2011-05-07 15:08:45 UTC
Package gnome-applet-alarm-clock-0.3.2-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-applet-alarm-clock-0.3.2-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-applet-alarm-clock-0.3.2-1.fc15
then log in and leave karma (feedback).

Comment 10 Christoph Wickert 2011-05-16 16:58:16 UTC
Can you please test the update?

Comment 11 Fedora Update System 2011-05-19 05:06:42 UTC
gnome-applet-alarm-clock-0.3.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.