Bug 699238 - x11 problem after kde 4.6.2 update
x11 problem after kde 4.6.2 update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-24 09:56 EDT by Dhiraj Kumar Hazra
Modified: 2011-09-22 02:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-03 13:57:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/yum.log (124.36 KB, text/plain)
2011-04-25 13:34 EDT, Dhiraj Kumar Hazra
no flags Details

  None (edit)
Description Dhiraj Kumar Hazra 2011-04-24 09:56:13 EDT
Description of problem:
from a different machine I logged on using ssh -X username@ipaddress. 
I am not able to open dolphin, gedit or any gui


Version-Release number of selected component (if applicable):
qt-x11-4.7.2-8.fc14.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
unnamed app(2508): KUniqueApplication: Cannot find the D-Bus session server:  "/bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed.
" 

unnamed app(2507): KUniqueApplication: Pipe closed unexpectedly. 


Expected results:


Additional info:
Comment 1 A S Alam 2011-04-24 23:29:34 EDT
have you tried after rebooting the Machine, which is updated?
Comment 2 Dhiraj Kumar Hazra 2011-04-25 04:35:51 EDT
Yes I rebooted the machine. qt-x11 was updated that's sure. I do not recall all the things that was updated. This was the best guess I could do. Would a dmesg help?
Comment 3 Rex Dieter 2011-04-25 08:53:09 EDT
look in /var/log/yum.log

or do 
$ yum history

for details about what was updated and when.

The fact that dbus-launch is failing with a low-level X11 initialization failure, means that things are going wrong on a lower level than qt/kde.
Comment 4 Dhiraj Kumar Hazra 2011-04-25 13:33:48 EDT
The yum history




Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
ID     | Login user             | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
    89 | Dhiraj ... <dhiraj>    | 2011-04-24 14:59 | O, U           |   84   
    88 | System <unset>         | 2011-04-20 17:06 | Update         |    7   
    87 | Dhiraj ... <dhiraj>    | 2011-04-19 15:38 | Update         |    9   
    86 | Dhiraj ... <dhiraj>    | 2011-04-19 13:40 | Erase          |   12   
    85 | Dhiraj ... <dhiraj>    | 2011-04-18 21:32 | I, U           |   98 EE
    84 | Dhiraj ... <dhiraj>    | 2011-04-18 16:45 | Install        |    5   
    83 | Dhiraj ... <dhiraj>    | 2011-04-13 13:26 | Install        |    1 EE
    82 | System <unset>         | 2011-04-11 10:39 | Update         |    7   
    81 | System <unset>         | 2011-04-10 13:36 | Update         |    2   
    80 | Dhiraj ... <dhiraj>    | 2011-04-09 12:47 | Install        |   18   
    79 | System <unset>         | 2011-04-08 14:24 | Install        |    1   
    78 | System <unset>         | 2011-04-08 14:21 | Install        |    1   
    77 | Dhiraj ... <dhiraj>    | 2011-04-08 13:05 | Install        |    3   
    76 | Dhiraj ... <dhiraj>    | 2011-04-08 12:48 | Update         |    6   
    75 | System <unset>         | 2011-04-08 10:50 | Install        |    7   
    74 | System <unset>         | 2011-04-07 18:39 | I, U           |    9   
    73 | System <unset>         | 2011-04-07 15:07 | Install        |    2   
    72 | System <unset>         | 2011-04-06 22:27 | Install        |   11   
    71 | Dhiraj ... <dhiraj>    | 2011-04-06 21:51 | Update         |    2   
    70 | System <unset>         | 2011-04-06 15:22 | Install        |    8   
history list
Comment 5 Dhiraj Kumar Hazra 2011-04-25 13:34:45 EDT
Created attachment 494719 [details]
/var/log/yum.log
Comment 6 Rex Dieter 2011-06-03 11:06:08 EDT
Is this still reproducible?
Comment 7 Dhiraj Kumar Hazra 2011-06-03 13:57:28 EDT
I am out of station . Anyway my friend has checked it for me. With 4.6.3 it works perfectly. no problem.
closing 
thanks 
dhiraj
Comment 8 Linuxguy123 2011-09-22 02:21:20 EDT
I've got this problem in KDE 4.6.5.

It worked fine last night, from several client machines.

Server details.

# uname -a
Linux server.localdomain 2.6.40.4-5.fc15.i686 #1 SMP Tue Aug 30 14:54:41 UTC 2011 i686 i686 i386 GNU/Linux

# yum list kdebase
Installed Packages
kdebase.i686                                               6:4.6.5-1.fc15    

# yum list openssh
Installed Packages
openssh.i686                                               5.6p1-34.fc15.1 


Client details

$ uname -a
Linux dragon.localdomain 2.6.40.4-5.fc15.i686 #1 SMP Tue Aug 30 14:54:41 UTC 2011 i686 i686 i386 GNU/Linux

$ yum list kdebase
Installed Packages
kdebase.i686                                               6:4.6.5-1.fc15  

$ yum list openssh
Installed Packages
openssh.i686                                               5.6p1-34.fc15.1 


Is there an open bug report for a newer version of this somewhere ?
Comment 9 Linuxguy123 2011-09-22 02:25:23 EDT
Here is what has changed on the server since it last worked.

Sep 21 20:42:35 Updated: 2:ntfs-3g-2011.4.12-5.fc15.i686
Sep 21 20:42:36 Installed: 2:ntfsprogs-2011.4.12-5.fc15.i686
Sep 21 20:42:37 Updated: flash-plugin-10.3.183.10-release.i386
Sep 21 20:42:37 Updated: cups-pk-helper-0.1.3-2.fc15.i686
Sep 21 20:43:41 Installed: 1:perl-HTML-Tree-4.1-2.fc15.noarch
Sep 21 20:43:41 Installed: 3:perl-version-0.88-3.fc15.i686
Sep 21 20:43:42 Installed: crystalhd-firmware-3.5.1-1.fc14.noarch
Sep 21 20:43:42 Installed: libcrystalhd-3.5.1-1.fc14.i686
Sep 21 20:43:43 Installed: libsigc++20-2.2.9-1.fc15.i686
Sep 21 20:43:43 Installed: glibmm24-2.28.1-1.fc15.i686
Sep 21 20:43:43 Installed: lame-3.98.4-1.fc14.i686
Sep 21 20:43:44 Installed: 1:perl-Net-UPnP-1.4.2-6.fc15.noarch
Sep 21 20:43:44 Installed: perl-MythTV-0.24.1-2.fc15.i686
Sep 21 20:43:44 Installed: libxml++-2.34.2-1.fc15.i686
Sep 21 20:43:45 Installed: libffado-2.1.0-0.3.20110426.svn1983.fc15.i686
Sep 21 20:43:45 Installed: libvdpau-0.4.1-4.fc15.i686
Sep 21 20:43:46 Installed: libfreebob-1.0.11-8.fc15.i686
Sep 21 20:43:46 Installed: ImageMagick-perl-6.6.5.10-19.fc15.i686
Sep 21 20:43:46 Installed: celt-0.10.0-2.fc15.i686
Sep 21 20:43:47 Installed: jack-audio-connection-kit-1.9.7-2.fc15.i686
Sep 21 20:43:49 Installed: mythtv-libs-0.24.1-2.fc15.i686
Sep 21 20:43:50 Installed: mythtv-common-0.24.1-2.fc15.i686
Sep 21 20:43:51 Installed: wget-1.12-4.fc15.i686
Sep 21 20:43:52 Installed: mythtv-backend-0.24.1-2.fc15.i686

Note You need to log in before you can comment on or make changes to this bug.