Bug 6993 - Problems with VJ compression with PPP
Problems with VJ compression with PPP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-13 17:57 EST by Tom Cross
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 18:31:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Cross 1999-11-13 17:57:08 EST
I have a RedHat 6.1 box with Dual Pentium-Pro processors.  The RH6.1
install correctly identified this and I'm currently using 2-2.12-20smp for
i686.

When I try to connect via PPP to the internet, I get the following in
/var/log/messages:
Nov 13 14:59:15 hal diald[1121]: Running pppd (pid = 1197).
Nov 13 14:59:15 hal modprobe: can't locate module char-major-108
Nov 13 14:59:15 hal pppd[1197]: pppd 2.3.10 started by root, uid 0
Nov 13 14:59:15 hal pppd[1197]: Using interface ppp0
Nov 13 14:59:15 hal pppd[1197]: Connect: ppp0 <--> /dev/ttyS0
Nov 13 14:59:21 hal pppd[1197]: Remote message: Login Succeeded
Nov 13 14:59:48 hal pppd[1197]: Connection terminated.
Nov 13 14:59:48 hal pppd[1197]: Exit.

I enabled debug for pppd and found this:


Nov 13 16:32:09 hal pppd[752]: rcvd [PAP AuthAck id=0x2 "Login Succeeded"]
Nov 13 16:32:09 hal pppd[752]: Remote message: Login Succeeded
Nov 13 16:32:09 hal pppd[752]: rcvd [IPCP ConfReq id=0x1 <compress VJ 0f00>
<addr 204.221.242.1>]
Nov 13 16:32:12 hal pppd[752]: rcvd [IPCP ConfReq id=0x2 <compress VJ 0f00>
<addr 204.221.242.1>]
Nov 13 16:32:15 hal pppd[752]: rcvd [IPCP ConfReq id=0x3 <compress VJ 0f00>
<addr 204.221.242.1>]
Nov 13 16:32:18 hal pppd[752]: rcvd [IPCP ConfReq id=0x4 <compress VJ 0f00>
<addr 204.221.242.1>]
Nov 13 16:32:22 hal pppd[752]: rcvd [IPCP ConfReq id=0x5 <compress VJ 0f00>
<addr 204.221.242.1>]


It LOOKS like it can't to VJ header compression.  I thought it might have
been a mis-compiled kernel so I recompiled make sure PPP was checked as a
module (it was).  My new kernel still did not work.

I will try this with a UP and post the results.

Is there a known problem with PPP/SMP/VJ?
Comment 1 Tom Cross 1999-11-15 12:23:59 EST
I tried the Uniprocessor kernel that the installer installed for me and I had
exactly the same results with PPP and VJ.
Comment 2 Michael K. Johnson 1999-11-19 16:38:59 EST
No, it can certainly do vj compression.

Can you give me the output of
rpm -q ppp initscripts

Thanks.
Comment 3 Tom Cross 1999-11-19 16:51:59 EST
[tomc@hal tomc]$ rpm -q ppp initscripts
ppp-2.3.10-3
initscripts-4.63-1


I forgot to mention that I have basically done a rpm -UvhF *.rpm from the 6.1
updates directory.
Comment 4 Nalin Dahyabhai 2000-02-29 09:24:59 EST
Others have reported that adding "novj" to their /etc/ppp/options file improves
things for them.  This is too rare an occurrence to be sure it's a bug in the
Linux ppp driver -- what kind of system is on the other end of the line?
Comment 5 Stephen John Smoogen 2003-01-24 18:31:23 EST
Bug 6993 is being closed because bug was needing info since 2000, and neither
original bug reporter or others added any information. 

Note You need to log in before you can comment on or make changes to this bug.