This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 699622 - autoconf: upgrade to 2.68
autoconf: upgrade to 2.68
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autoconf (Show other bugs)
6.2
All All
medium Severity medium
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-tools
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-26 04:09 EDT by Jim Meyering
Modified: 2016-07-25 04:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 04:19:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Meyering 2011-04-26 04:09:53 EDT
Description of problem: providing an out of date version imposes undue burden on developers who use RHEL and penalizes their users.

Currently, RHEL6.x provides autoconf-2.63 from more than 3.5 years ago.

Autoconf is similar to gettext and automake in that its primary output is consumed indirectly by users running on all sorts of different systems.
autoconf is typically run only by developers, to create configure scripts
that are then run only when users build from source.  Since the consumers
of a package that was built on RHEL6.x may be using any type of system,
we have a duty to provide a reasonably up to date version of this tool.
Autoconf is not like a library where end user applications rely on it at
run time, and in fact the savvy developer can install his/her own version
of autoconf and use that independently of the one provided by the system.
However, that process is error-prone enough (integrating with automake,
libtool, gettext, m4) that it is best done for all.

I suggest an upgrade to 2.68.  Note that there has been no significant
bug fix since that release 7 months ago (the AS_LITERAL_IF thing is minor)
Note that Fedora 14 uses 2.66, in spite of the fact that NEWS indicates that numerous bugs fixed in 2.68 were introduced in 2.66. 

For a summary of the changes since 2.63, see its NEWS file:

  http://git.savannah.gnu.org/cgit/autoconf.git/tree/NEWS


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2011-04-26 04:38:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Jim Meyering 2011-04-26 08:57:16 EDT
Gettext in RHEL5 was in the same boat not long ago.  Witness some of
the problems we developers faced before I got a relatively modern gettext
into RHEL5: http://bugzilla.redhat.com/523713

And that's just the tip of the iceberg.  If you need more,
I can find tens of examples/testimonials showing how penalizing
it is to have out-of-date autotools in RHEL.
Comment 4 RHEL Product and Program Management 2011-07-05 21:36:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Jim Meyering 2011-10-10 12:26:59 EDT
The arguments made above are still just as relevant, and now it's been a year since the release of autoconf-2.68.
Comment 6 Karsten Hopp 2012-06-28 08:46:41 EDT
A rebase of autoconf can't break any existing applications and would help developers as mentioned in the bug description
Comment 7 Jim Meyering 2012-07-02 03:47:09 EDT
Coincidentally, just today Bruno Haible diagnosed a tricky
bug that was triggered by using RHEL6's autoconf-2.63:

  http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/31195

As he notes, autoconf-2.64 would have generated working code
and would have warned about the problematic ordering.
autoconf-2.63 does neither.
Comment 8 RHEL Product and Program Management 2012-07-10 02:44:00 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 Jim Meyering 2012-07-10 07:14:43 EDT
This really does matter.
Please consider it for rhel-6.5.

In fact, now you should consider the newer autoconf-2.69.
Comment 10 RHEL Product and Program Management 2012-07-10 19:05:16 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 12 RHEL Product and Program Management 2013-10-13 21:06:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 16 Pavel Raiskup 2016-07-25 04:19:16 EDT
We reached production phase 2, and it is now really too late for rebases.
Sorry and thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.