Bug 69970 - userhelper gui issues
Summary: userhelper gui issues
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: usermode (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-27 03:52 UTC by Alex Yacoub
Modified: 2007-04-18 16:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 04:24:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Yacoub 2002-07-27 03:52:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
In the Limbo beta, using metacity with sloppy focus, userhelper password dialog
boxes have a tendency to very very quickly drop below other windows.  In some
cases, the dialog grabs and holds keyboard focus (though not window focus).

To solve this, the userhelper dialgs need to be set as "Always on Top" when they
are created.

Version-Release number of selected component (if applicable):
1.55-4

How reproducible:
Always

Steps to Reproduce:
Run any program that uses userhelper wrappers.  Do this preferably from a gui
tool (nautilus or a menu) with windows open.  The userhelper dialog will drop to
the bottom unless the mouse happens to be where it pops up.	

Additional info:

Comment 1 Nalin Dahyabhai 2002-08-13 02:42:24 UTC
Are you using autoraise?  If so, then this is unavoidable.

Consider the situation where you have two "always on top" windows which
overlapped (fairly likely, given that userhelper dialogs are always centered). 
The window manager would have no way of knowing for certain which belonged on
top at any given moment, and Bad Things could happen.

I'm going to mark this WONTFIX because the GUI toolkit doesn't offer a standard
ALWAYSONTOP hint, I suspect for this or a related reason.


Note You need to log in before you can comment on or make changes to this bug.