Bug 69977 - process start time moving 10x system clock time
process start time moving 10x system clock time
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: procps (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-27 13:02 EDT by Tim Clymo
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 05:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2002-07-27 13:02:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
This may well be a kernel bug since I guess ps simply reads and formats
information placed under /proc - however, from a gnome-terminal:

$ date
Sat Jul 27 17:54:03 BST 2002
$ uptime
  5:54pm  up 32 min,  0 users,  load average: 0.00, 0.06, 0.06
$ while true; do ps -f|grep ps|grep -v grep; sleep 1; done
timc      4326  4009  0 22:56 pts/1    00:00:00 ps -f
timc      4330  4009  0 22:56 pts/1    00:00:00 ps -f
timc      4334  4009  0 22:57 pts/1    00:00:00 ps -f
timc      4338  4009  0 22:57 pts/1    00:00:00 ps -f
timc      4342  4009  0 22:57 pts/1    00:00:00 ps -f
timc      4346  4009  0 22:57 pts/1    00:00:00 ps -f
timc      4350  4009  0 22:57 pts/1    00:00:00 ps -f
timc      4354  4009  0 22:57 pts/1    00:00:00 ps -f
timc      4358  4009  0 22:58 pts/1    00:00:00 ps -f
timc      4362  4009  0 22:58 pts/1    00:00:00 ps -f
timc      4366  4009  0 22:58 pts/1    00:00:00 ps -f
timc      4370  4009  0 22:58 pts/1    00:00:00 ps -f
timc      4374  4009  0 22:58 pts/1    00:00:00 ps -f
timc      4378  4009  0 22:59 pts/1    00:00:00 ps -f
timc      4382  4009  0 22:59 pts/1    00:00:00 ps -f
timc      4386  4009  0 22:59 pts/1    00:00:00 ps -f
timc      4390  4009  0 22:59 pts/1    00:00:00 ps -f
timc      4394  4009  0 22:59 pts/1    00:00:00 ps -f
timc      4398  4009  0 22:59 pts/1    00:00:00 ps -f

Note the process start time in field #5. Given that there is approximately 1 sec
between each iteration of the ps command, I'd expect to see about 60 successive
lines showing the same hh:mm time before it incremented the next minute. In
addition, the hh:mm should be the same time as the system time.

In this case, the system had been up only around 30 mins, and process start
times are showing 5hrs into the future.

I'm using kernel 2.4.18-5.73 and procps 2.0.7-21

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.See description
2.
3.
	

Additional info:
Comment 1 Alexander Larsson 2002-08-07 05:49:53 EDT
This was recently fixed in the kernel. Can you upgrade to the latest kernel in
rawhide and verify that it is fixed.
Comment 2 Tim Clymo 2002-08-07 08:25:09 EDT
Seems to be fixed in kernel-2.4.18-7.80 - thanks

Note You need to log in before you can comment on or make changes to this bug.