Bug 69982 - konsole showed weird characters when running mc
konsole showed weird characters when running mc
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-27 14:00 EDT by Fortepianissimo
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-27 14:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
garbled characters in konsole (51.32 KB, image/png)
2002-07-27 14:01 EDT, Fortepianissimo
no flags Details
garbled screen (LANG=en_US.UTF-8) (50.82 KB, image/png)
2002-07-30 01:05 EDT, Fortepianissimo
no flags Details

  None (edit)
Description Fortepianissimo 2002-07-27 14:00:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020718

Description of problem:
When running mc (Midnight Commander) under Konsole some of the chacaters are
garbled. See the attached snapshot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run konsole
2.run mc inside the konsole
3.
	

Actual Results:  Some characters (e.g., border lines) are garbled. When pulling
down menu, characters can be seen overlaid on top of the background texts.

Changing to other fonts showed the same garbled texts.

Additional info:

Attached is the snapshot of the konsole window.

Here are the relevant packages:

mc-4.5.55-11
kdebase-3.0.2-6
qt-3.0.5-3
Xft-1.9.1.020708.0036-2
XFree86-4.2.0-55
freetype-2.1.2-5
fontconfig-0.0.1.020626.1517-6
Comment 1 Fortepianissimo 2002-07-27 14:01:36 EDT
Created attachment 67344 [details]
garbled characters in konsole
Comment 2 Bill Nottingham 2002-07-29 00:33:53 EDT
This is most likely not a konsole bug. Upgrading to the latest mc, slang, and
initscripts should solve this issue.
Comment 3 Fortepianissimo 2002-07-29 23:42:25 EDT
Here are the packages I have installed:

initscripts-6.88-1
slang-1.4.5-11
slang-devel-1.4.5-11
mc-4.5.55-11
ncurses-5.2-28

I believe they are most up-to-date at this point. But I still get the garbled
characters?

In addition, it seems that other text-based programs, such as ntsysv, has
exactly the same problem under konsole. But they are fine under text console
(well at least tty1).
Comment 4 Fortepianissimo 2002-07-30 00:57:15 EDT
Well turned out that I set LANG to en_US the other day and forgot to turn it
back. After setting LANG="en_US.UTF-8" in /etc/sysconfig/i18n the problem was
alleviated a little: I still got garbled characters (see the new snapshot), but
with a different weird character as the borderline char; as to pulling down
menus showed background texts through the forground, it's now gone.
Comment 5 Fortepianissimo 2002-07-30 01:05:47 EDT
Created attachment 67625 [details]
garbled screen (LANG=en_US.UTF-8)
Comment 6 Fortepianissimo 2002-08-22 16:22:07 EDT
ok it's fixed in (null).

Note You need to log in before you can comment on or make changes to this bug.