Bug 699970 - Translations for subscription-manager 5.7 release need to be complete.
Translations for subscription-manager 5.7 release need to be complete.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 715031
  Show dependency treegraph
 
Reported: 2011-04-27 02:13 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:40:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to update translations of subscription-manager for Russian (ru.po) (979 bytes, patch)
2011-06-21 03:24 EDT, Ankit Patel
no flags Details | Diff
Unsubscribe subscription dialog-Unlocalized (12.12 KB, image/jpeg)
2011-06-24 05:57 EDT, Lijun Li
no flags Details
Invalid credentials message in ko_KR (170.92 KB, image/png)
2011-06-27 02:52 EDT, Kenichi Takemura
no flags Details
Invalid credentials message in zh_TW (114.94 KB, image/png)
2011-06-27 02:53 EDT, Kenichi Takemura
no flags Details
Invalid credentials message in de_DE (19.81 KB, image/jpeg)
2011-06-27 03:30 EDT, Lijun Li
no flags Details
Unsubscribe subscription dialog-Unlocalized in de-DE (11.78 KB, image/jpeg)
2011-06-27 03:39 EDT, Lijun Li
no flags Details
Invalid credentials message in ru_RU (19.75 KB, image/jpeg)
2011-06-27 07:37 EDT, Lijun Li
no flags Details
Error message occured in unsubscribe from a subscription (81.06 KB, image/jpeg)
2011-06-28 04:50 EDT, Lijun Li
no flags Details

  None (edit)
Description Kenichi Takemura 2011-04-27 02:13:08 EDT
Description of problem:

Translations for subscription-manager 5.7 release need to be complete.

Here is the status of subscription-manager translation from RHEL 5 repo.

as.po
330 translated messages, 3 untranslated messages.
bn.po
330 translated messages, 3 untranslated messages.
de.po
330 translated messages, 3 untranslated messages.
es.po
330 translated messages, 3 untranslated messages.
fr.po
330 translated messages, 3 untranslated messages.
gu.po
330 translated messages, 3 untranslated messages.
hi.po
330 translated messages, 3 untranslated messages.
it.po
330 translated messages, 3 untranslated messages.
ja.po
328 translated messages, 2 fuzzy translations, 3 untranslated messages.
kn.po
330 translated messages, 3 untranslated messages.
ko.po
328 translated messages, 2 fuzzy translations, 3 untranslated messages.
ml.po
330 translated messages, 3 untranslated messages.
mr.po
330 translated messages, 3 untranslated messages.
or.po
330 translated messages, 3 untranslated messages.
pa.po
329 translated messages, 1 fuzzy translation, 3 untranslated messages.
pt_BR.po
328 translated messages, 2 fuzzy translations, 3 untranslated messages.
pt.po
284 translated messages, 49 untranslated messages.
ru.po
330 translated messages, 3 untranslated messages.
ta.po
328 translated messages, 2 fuzzy translations, 3 untranslated messages.
te.po
330 translated messages, 3 untranslated messages.
zh_CN.po
330 translated messages, 3 untranslated messages.
zh_TW.po
330 translated messages, 3 untranslated messages.
Comment 1 Ankit Patel 2011-04-28 01:58:51 EDT
Hi Christopher,

There is a typo found.

string no 132: RHSM Subscriptions Managemen

typo: 'Managemen' should be 'Management'

Could you please correct it and generate a new POT file for us? We have completed translation except above, as it requires modification.

Thanks!
Ankit
Comment 2 Chris Duryee 2011-04-28 09:33:25 EDT
The typo has been corrected, in hash 42d8706781562c7640ded6a6a6a28251ef287848.
Comment 3 Chris Duryee 2011-05-31 10:26:52 EDT
The latest translations have been merged up, and will be in 0.95.5.19 and above.
Comment 6 Kenichi Takemura 2011-06-21 01:13:28 EDT
Hi Ankit.

Could you make sure following Russian translation is ok?

"...................................." is a valid string?

#: ../src/subscription_manager/managercli.py:372
#: ../src/subscription_manager/managercli.py:536
msgid ""
"automatically subscribe this system to                                     "
"compatible subscriptions."
msgstr ""
"автоматически подписать систему .................................... на "
"подходящие подписки."

This string appears like below.

>>> Command:  subscription-manager subscribe -help
>>> Output starts <<<
формат: subscription-manager subscribe [OPTIONS]

subscribe

options:
  -h, --help            показать это сообщение и
                        выйти
  --debug=DEBUG         уровень отладки
  --proxy=PROXY_URL     адрес прокси в формате
                        «узел:порт»
  --proxyuser=PROXY_USER
                        пользователь на прокси HTTP с
                        минимальной аутентификацией
  --proxypassword=PROXY_PASSWORD
                        пароль для доступа к прокси
                        HTTP с минимальной
                        аутентификацией
  --pool=POOL           id пула подписки
  --auto                автоматически подписать
                        систему ....................................
                        на подходящие подписки.
>>> Output ends [ret=0]<<<
Comment 7 Ankit Patel 2011-06-21 02:04:56 EDT
Yulia,

Can you please look at the comment #6 ?

Thanks!
Ankit
Comment 8 Yulia 2011-06-21 03:16:14 EDT
I am not sure how spaces got replaced with dots but I have reverted it back and submitted changes to the repository.
Comment 9 Ankit Patel 2011-06-21 03:24:39 EDT
Created attachment 505765 [details]
A patch to update translations of subscription-manager for Russian (ru.po)

Created a patch based on submissions made by Yulia, as reported in comment #8. Applying this patch should fix the reported Russian Translation issue. Please include it in your next build in order to resolve this bug.

Thanks!
Ankit
Comment 12 Lijun Li 2011-06-24 05:57:51 EDT
Created attachment 509724 [details]
Unsubscribe subscription dialog-Unlocalized

Dialog: the string "Are you sure you want to unsubscribe from Red Hat Employee Subscription? " is not localized. it should be localized.
Comment 13 Kenichi Takemura 2011-06-27 02:51:41 EDT
Invalid username or password. To create a login, please visit...

is not translated in ko_KR and zh_TW etc. but is translated for ja_JP and zh_TW.
Comment 14 Kenichi Takemura 2011-06-27 02:52:29 EDT
Created attachment 510025 [details]
Invalid credentials message in ko_KR
Comment 15 Kenichi Takemura 2011-06-27 02:53:36 EDT
Created attachment 510026 [details]
Invalid credentials message in zh_TW
Comment 16 Ankit Patel 2011-06-27 02:57:10 EDT
Hi Eun-Ju, Terry,

Could you please check the attachment 510025 [details] and attachment 510025 [details] and confirm whether it requires any modifications to the translations?

Thanks!
Ankit
Comment 17 Lijun Li 2011-06-27 03:30:02 EDT
Created attachment 510030 [details]
Invalid credentials message in de_DE

Invalid credentials message in de_DE
Comment 18 Lijun Li 2011-06-27 03:39:31 EDT
Created attachment 510032 [details]
Unsubscribe subscription dialog-Unlocalized in de-DE
Comment 19 Ankit Patel 2011-06-27 05:01:35 EDT
Hi Hedda,

Can you please take a look at the Germen for attachment 510030 [details] and attachment 510032 [details]?

Thanks!
Ankit
Comment 20 Lijun Li 2011-06-27 07:37:44 EDT
Created attachment 510075 [details]
Invalid credentials message in ru_RU
Comment 21 Hedda Peters 2011-06-27 18:12:56 EDT
Hi Ankit,
yes, those two strings in those two screenshots obviously still need to be translated into German. Where do I find them? They are not in my local subscription manager po-files.

Thanks
Hedda
Comment 23 Ankit Patel 2011-06-28 01:43:23 EDT
Hi Yulia,

Can you please check the attachment 510075 [details] and confirm whether it needs any correction?

Thanks!
Ankit
Comment 24 Yulia 2011-06-28 01:55:47 EDT
Hi Ankit,

I just checked and there is no such string in the PO-file. Where does it come from?

Yulia
Comment 25 Hedda Peters 2011-06-28 01:59:55 EDT
Ankit,
same here, what Yulia says:

I checked out the files fresh again from the repo you mentioned. The de-DE file is 100% translated.

1) I found the string "Are you sure you want to unsubscribe from %s?", which could be the one showing in attachment 510032 [details]. However, it's fully translated into German.

2) I didn't find the second string in question "Invalid username or password. To create...." from attachment 510030 [details] at all in these po files.

Let us know what to do.
Hedda
Comment 26 Lijun Li 2011-06-28 04:50:09 EDT
Created attachment 510223 [details]
Error message occured in unsubscribe from a subscription

Error message occured in unsubscribe from a subscription

Steps:
1. Register System using RHN account and password selecting 'select the most appropriate subscriptions for this system option'.

2. Unsubscribe (30 day Unsupported Red Hat Enterprise Linux Server, (4 sockets) (Unlimited guests) Evaluation) from the subscription.
Comment 27 Ankit Patel 2011-06-28 06:30:52 EDT
(In reply to comment #24)
> Hi Ankit,
> 
> I just checked and there is no such string in the PO-file. Where does it come
> from?
> 
> Yulia

Hi Yulia,

Thanks for the quick verification. I confirm that it comes from server messages. It's not at all available for translations in PO files of subscription-manager.

Developers will look into it.

Thanks!
Ankit
Comment 28 Ankit Patel 2011-06-28 06:33:46 EDT
(In reply to comment #25)
> Ankit,

Hi Hedda,

> same here, what Yulia says:
> 
> I checked out the files fresh again from the repo you mentioned. The de-DE file
> is 100% translated.
> 
> 1) I found the string "Are you sure you want to unsubscribe from %s?", which
> could be the one showing in attachment 510032 [details]. However, it's fully translated
> into German.

Yep, got it. It may appear translated in the next build when Developer includes the latest translations.

> 
> 2) I didn't find the second string in question "Invalid username or password.
> To create...." from attachment 510030 [details] at all in these po files.

I found it.

#######################################
#: ../src/subscription_manager/constants.py:54
#, python-format
msgid ""
"<b>Unable to register the system.</b>\n"
"\n"
" %s\n"
"\n"
"Please see /var/log/rhsm/rhsm.log for more information."
msgstr ""
"<b>System konnte nicht registriert werden.</b>\n"
"\n"
" %s\n"
"\n"
"Siehe /var/log/rhsm/rhsm.log für weitere Informationen."
#######################################

Basically, the untranslated message comes from server errors (REGISTER_ERROR variable value I can see from constants.py from the source.

Developers will look into it.

Thanks Hedda!

Btw, good testing by Lijun Li. Thanks!

/Ankit


> 
> Let us know what to do.
> Hedda
Comment 29 Bryan Kearney 2012-01-04 15:11:00 EST
Latest Strings brought in and this resolves the issues.
Comment 31 Lijun Li 2012-01-13 07:18:12 EST
Verified on subscription-manager-0.98.10-1.el5
"Are you sure unsubscribe..." dialog are all localized, but for unlocalized message 'Invalid username or password...' still not fixed for some langs, bug 752722 for tracking this (https://bugzilla.redhat.com/show_bug.cgi?id=752722).
Comment 32 William Poteat 2012-01-20 12:02:18 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary
Comment 33 John Sefler 2012-01-24 09:38:10 EST
Many of the comments in this bug have deviated from the original general problem.
If your specific issues have not already been fixed by comment 2 comment 3 comment 9 comment 10 comment 29 please open a new bug.

Moving this bug to VERIFIED as part of the RHEL-5.8.0 errata.
Comment 35 errata-xmlrpc 2012-02-21 01:40:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0154.html

Note You need to log in before you can comment on or make changes to this bug.