Bug 700155 - why does bluedevil require pulseaudio ?
Summary: why does bluedevil require pulseaudio ?
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bluedevil (Show other bugs)
(Show other bugs)
Version: 14
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 701181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-27 15:46 UTC by kakashizilla
Modified: 2011-05-02 00:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 16:00:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kakashizilla 2011-04-27 15:46:08 UTC
Description of problem:

The package bluedevil requires pulseaudio-module-bluetooth, which requires pulseaudio.
There are still users that do not want pulseaudio.
bluedevil does not really need pulseaudio-module-bluetooth.
I guess the dependency has been added to be convenient, but it is a mess for non-pulseaudio users.

Please, remove this dependancy.

Version-Release number of selected component (if applicable):
bluedevil 1.1-1

Comment 1 Kevin Kofler 2011-04-27 16:00:46 UTC
> why does bluedevil require pulseaudio ?

For the same reason gnome-bluetooth does (and has done for 2 years now).

Quoting from there, with s/gnome-bluetooth/BlueDevil/:
> pulseaudio-module-bluetooth is required by [BlueDevil], so that speakers
> and headsets work out of the box. […snip…] [BlueDevil] needs to
> have the pulseaudio-module-bluetooth package install to do anything with audio
> headsets.

Or in short:
> PulseAudio is required to get out-of-the-box support for Bluetooth audio
> devices.

See bug 497703 and bug 571627, both closed NOTABUG.

Comment 2 kakashizilla 2011-04-27 17:28:28 UTC
Well, that is what I feared...

Here a suggestion : is it possible to use a metapackage ?
For instance, a package 'bluedevil-core' containing only bluedevil,
and a metapackage 'bluedevil' installing 'bluedevil-core' and 'pulseaudio-module-bluetooth'.
So, everything can still work out-of-the-box for pulseaudio users, and the others just have ot install the core package.

Please, take this request in consideration for the benefits of _all_ the users.

Comment 3 Rex Dieter 2011-04-27 17:35:35 UTC
good idea, we'll talk it over.

Comment 4 Kevin Kofler 2011-05-01 22:26:54 UTC
*** Bug 701181 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Kofler 2011-05-01 22:56:21 UTC
*** Bug 701181 has been marked as a duplicate of this bug. ***

Comment 6 Kevin Kofler 2011-05-02 00:20:17 UTC
*** Bug 701181 has been marked as a duplicate of this bug. ***

Comment 7 Kevin Kofler 2011-05-02 00:53:17 UTC
*** Bug 701181 has been marked as a duplicate of this bug. ***

Comment 8 Kevin Kofler 2011-05-02 00:55:19 UTC
Sorry for the bugspam, but the reporter of the duplicate keeps insisting that "why does bluedevil require pulseaudio ?" is not the same bug as "bluedevil drags in pulseaudio through dependencies". :-/


Note You need to log in before you can comment on or make changes to this bug.