Bug 70072 - Won't restart X on logout when change done under non-root account
Won't restart X on logout when change done under non-root account
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 67046 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-29 18:49 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 08:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-29 18:49:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
When changing the display settings via redhat-config-xfree8 (launched from the
menu under "System Tools/Display Configuration"), the program states that
changes will take effect after logout.  This works when doing this logged in as
root, but when done as a regular user, X doesn't restart. The changes do take
effect if X is manually restarted (ctrl-alt-backspace works).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.As non-root user, from the gnome menu run System Tools/Display Configuration &
enter the root pasword when prompted.
2.Make changes.
3.Logout
	

Actual Results:  X doesn't restart on logout from normal user account after
making config changes in redhat-config-xfree86, but does restart if
redhat-config-xfree86 was run from within a root session.

Expected Results:  X should restart even if this was done under normal user
session, since the user is prompted for the root password befure making changes,
and the changes are applied to /etc/X11/XF86Config.

Additional info:

Limbo running on dual Pentium II 350, 256Mb RAM, SMP kernel, NVIdia RIVA TNT2
AGP card, tried both XFree's "nv" driver and NVidia's "nvidia" driver with the
same results.
Comment 1 Alexander Larsson 2002-08-07 06:07:39 EDT
hp, i think this is actually a gdm setting AlwaysResetServer or something like
that. Should we enable that?
Comment 2 Havoc Pennington 2002-08-07 09:16:54 EDT
I know we've discussed toggling that gdm setting before, but I remember none of
the arguments for/against.
Comment 3 George Lebl 2002-08-07 13:25:50 EDT
Setting AlwaysResetServer is more of a hack.  Applications shouldn't depend on X
being killed and restarted on logout/login.  It is much nicer, faster less
flickery to not restart the server but to just HUP it and have it regenerate
itself.  I suppose it could even be safer on buggy video cards.  Perhaps there
should be some way to lett gdm know that the session wants a restart.

I'm just adding a command to the fifo protocol to do this.  one would need to do
soemthing like:

if [ -e /var/gdm/.gdmfifo ]; then
   (echo;echo DIRTY_SERVERS) > /var/gdm/.gdmfifo
fi

Or follow the example in the gdm.spec for SOFT_RESTART (that will fetch the
proper directory of the .gdmfifo file no matter what it's set to in the config
file).  Also doing this on an older version of gdm has no effect so it's safe to
do.  (well it's not in cvs yet, but will be momentairly)
Comment 4 Havoc Pennington 2002-08-07 14:27:49 EDT
having a special way for redhat-config-xfree86 to force a server restart sounds
like a nice solution to me.
Comment 5 George Lebl 2002-08-07 14:57:00 EDT
I'm also adding SOFT_RESTART_SERVERS command which is mostly like DIRTY_SERVERS
but if a user is not logged in on one of them it will restart the X server right
away.  This may be a bit too harsh to do without the user asking for it.  But it
may also be useful.

Just committed all this bit to CVS

Hmmmm, perhaps I should write some docs on all this as well someday
Comment 6 Alexander Larsson 2002-08-09 04:48:47 EDT
*** Bug 67046 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Larsson 2002-08-09 04:53:53 EDT
George, is there a released version with this in yet?
Comment 8 Alexander Larsson 2002-08-09 08:44:57 EDT
Ok. This should be fixed in redhat-config-xfree86 0.6.0-1 and gdm 2.4.0.7-1.
Comment 9 Jay Turner 2002-08-14 15:42:21 EDT
Fix confirmed with redhat-config-xfree86-0.6.0-1 and gdm-2.4.0.7-1.

Note You need to log in before you can comment on or make changes to this bug.