Bug 70081 - Segmentation Fault while compling PHP-4.2.2
Segmentation Fault while compling PHP-4.2.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-29 23:18 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 13:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-29 23:18:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611

Description of problem:
Not to sure how how to classify, please pardon inarticulateness.
While compling PHP 4.2.2 on my RH7.3 install I got a "Segmentation Fault" and
then it asked me to submit a bug report so here it is.
Dump looks like:
In file included from /usr/include/math.h:350, from
/rpm/php-4.2.2/main/php_config.h:2107, from /rpm/php-4.2.2/Zend/zend_config.h:1,
from /rpm/php-4.2.2/Zend/zend.h:48, from /rpm/php-4.2.2/main/php.h:34, from
string.c:26
/usr/include/bits/mathinline.h: In functions '__sgnl':
/usr/include/bits/mathinline.h: 291: Internal error: Segmentation fault.
Please submit a full bug report
then the bugzilla URL then
make[3]: *** [string.lo] Error 1
make[3]: Leaving directory '/rpm/php-4.2.2/ext/standard'
make[2]: *** [install-recursive] Error 1
make[2]: LEaving Directory '/rpm/php-4.2.2/etx/standard'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving....
you see how that goes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Download PHP4.2.2 tarball.
2. ./configure --with-openssl --diable-short-tags --with-jpeg-dir --with-mysql
--enable-sockets --with-regexp=php --with-apxs
3. make clean install
	

Actual Results:  n file included from /usr/include/math.h:350, from
/rpm/php-4.2.2/main/php_config.h:2107, from /rpm/php-4.2.2/Zend/zend_config.h:1,
from /rpm/php-4.2.2/Zend/zend.h:48, from /rpm/php-4.2.2/main/php.h:34, from
string.c:26
/usr/include/bits/mathinline.h: In functions '__sgnl':
/usr/include/bits/mathinline.h: 291: Internal error: Segmentation fault.
Please submit a full bug report
then the bugzilla URL then
make[3]: *** [string.lo] Error 1
make[3]: Leaving directory '/rpm/php-4.2.2/ext/standard'
make[2]: *** [install-recursive] Error 1
make[2]: LEaving Directory '/rpm/php-4.2.2/etx/standard'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving....
you see how that goes.

Expected Results:  SHould have made and installed PHP 4.2.2

Additional info:  I ran again and got a Segmentation Fault in thr_mutex.lo? 
Does "Segmentation Fault" perhpas mean my hardware is going to the toilet? 
Please let me know since I'm a n00b to this...bug only filed cause the OS asked
me to.

/B
Comment 1 Jakub Jelinek 2002-07-30 05:27:46 EDT
If you get errors at random places and when running again it happens elsewhere,
it is because of flaky hardware.
Comment 2 Need Real Name 2002-07-30 13:56:55 EDT
jakub@redhat.com,
    Will you please close this...I saw this error now in a few different places.
 I think you sould close this bug cause my hardware is garbage.

/B

Note You need to log in before you can comment on or make changes to this bug.