Bug 700818 (libircclient) - Review Request: libircclient - Library implementing client-server IRC protocol
Summary: Review Request: libircclient - Library implementing client-server IRC protocol
Status: CLOSED DUPLICATE of bug 817306
Alias: libircclient
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: 700814
TreeView+ depends on / blocked
Reported: 2011-04-29 13:38 UTC by Adam Huffman
Modified: 2012-07-18 15:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-05-19 19:29:34 UTC
Type: ---

Attachments (Terms of Use)

Description Adam Huffman 2011-04-29 13:38:55 UTC
Spec URL: http://verdurin.fedorapeople.org/reviews/libircclient/libircclient.spec
SRPM URL: http://verdurin.fedorapeople.org/reviews/libircclient/libircclient-1.3-5.fc14.src.rpm

It is designed to be small, fast, portable and compatible to RFC standards,
and most IRC clients. libircclient features include:
  * Full multi-threading support.
  * Single threads handles all the IRC processing.
  * Support for single-threaded applications, and socket-based
    applications, which use select()
  * Synchronous and asynchronous interfaces.
  * CTCP support with optional build-in reply code.
  * Flexible DCC support, including both DCC chat, and DCC file transfer.
  * Can both initiate and react to initiated DCC.
  * Can accept or decline DCC sessions asynchronously.
  * Plain C interface and implementation (possible to use from C++ code,
  * Compatible with RFC 1459 and most IRC clients.
  * Free, licensed under LGPL license.
  * Good documentation and examples available.

Comment 1 Adam Huffman 2011-04-29 13:42:52 UTC
This is based on the work of Conrad Meyer at:


There is a problem with debuginfo generation which I haven't yet been able to fix.

Comment 2 Michael Schwendt 2011-05-02 10:16:44 UTC
Not a full review:

> gcc -shared -Wl,-soname,libircclient.so.1 libircclient.o -o libircclient.so

You've got it backwards. With a soname of libirrclient.so.1, the file name ought to be libircclient.so.1 with the *.so symlink pointing to it.

> %files
> ...
> %{_libdir}/libircclient.so*

Here a dot is missing. It must be


so you can include the *.so symlink in the -devel package where it belongs.

> There is a problem with debuginfo generation which I haven't yet been able
> to fix.

The problem is the "-s" that strips the library:
install -s -m 0755 libircclient.so %{buildroot}%{_libdir}/


> /usr/share/doc/libircclient-1.3/examples/

Looks like the wrong subpackage for these examples. The included Makefile* for these examples are not usable, btw.

Comment 3 Adam Huffman 2011-05-02 11:00:24 UTC
Thanks for taking a look and clearing up my confusion regarding sonames.  I think that was part of the debuginfo problem, too - I'd added the '-s' flag in desperation as nothing else I'd tried had fixed it.

The documentation for this on the wiki isn't particularly clear, I found.

New version at:



Comment 4 Susi Lehtola 2012-01-04 21:12:54 UTC
It is rather odd that the package uses autotools in some way, but doesn't really use them for the compilation or for the generation of the libraries...

Comment 5 Adam Huffman 2012-01-08 12:18:25 UTC
Yes, I ended up ignoring the upstream makefiles.  However, it still needs config.h, which is why I still run configure.

New version at:



Comment 6 Susi Lehtola 2012-01-08 12:34:49 UTC
The warnings

dcc.c: In function 'libirc_dcc_process_descriptors':
dcc.c:333:8: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
dcc.c:369:31: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]

should be fixed before the package is approved. This kind of pointer handling can cause crashes.

Comment 7 Adam Huffman 2012-01-08 17:31:52 UTC
I've contacted upstream about these warnings.  If there's no response then I'll fix them myself.

Comment 9 Susi Lehtola 2012-01-19 21:03:02 UTC
Looks like version 1.5 was released yesterday.

Comment 10 Adam Huffman 2012-01-19 22:15:57 UTC
Hmm, nothing new in the ChangeLog.  Will take a look tomorrow.  Thanks for letting me know.

Comment 11 Adam Huffman 2012-01-20 13:30:35 UTC
Update to new upstream release 1.5 at:



The patches to fix those warnings don't seem to be necessary any more so I've disabled them.

Comment 12 Paulo Andrade 2012-05-19 19:29:34 UTC
I did not know about this request, as I became a fedora contributor
recently, and from several review requests I had, libircclient was
the one I got a sponsor.
I need libirrclient (and miniupnpc waiting for review) for my megaglest
package to be reviewed.

libircclient 1.6 was packaged.

Since the bug is for rawhide I believe it can be closed as duplicate.

*** This bug has been marked as a duplicate of bug 817306 ***

Comment 13 Paulo Andrade 2012-05-20 17:52:34 UTC
Adam, I invite you to be a libirclient comaintainer :-)

Please login and request acl at

for commit and approveacls

Note You need to log in before you can comment on or make changes to this bug.