Bug 701055 - syslog is flooded with messages from dbus when systemadm is started
Summary: syslog is flooded with messages from dbus when systemadm is started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-30 17:19 UTC by Lukas Middendorf
Modified: 2013-03-06 04:07 UTC (History)
9 users (show)

Fixed In Version: dbus-1.4.6-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-05 05:07:19 UTC
Type: ---


Attachments (Terms of Use)

Description Lukas Middendorf 2011-04-30 17:19:21 UTC
Description of problem:
When systemadm is started, a lot of lines
dbus: [system] Service 'org.freedesktop.systemd1' is already active
appear in /var/log/messages . At some point rsyslogd does rate limiting and drops further messages.

Version-Release number of selected component (if applicable):
systemd-26-1.fc15.i686
dbus-1.4.6-3.fc15.i686

How reproducible:
seems to happen always

Steps to Reproduce:
1. start sytemadm
2. look at /var/log/messages
  
Actual results:
a flood of identical messages with much more dropped because of rate limiting

Expected results:
no messages, or very few

Additional info:
Not sure if this problem really is in dbus or systemadm. I selected systemd because this is the component that triggers the bug.

Comment 1 Lennart Poettering 2011-05-02 13:41:40 UTC
dbus probably shouldn't generate these messages.

Comment 2 Fedora Update System 2011-05-02 17:43:36 UTC
dbus-1.4.6-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dbus-1.4.6-4.fc15

Comment 3 Fedora Update System 2011-05-03 04:26:47 UTC
Package dbus-1.4.6-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dbus-1.4.6-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dbus-1.4.6-4.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-05-05 05:07:13 UTC
dbus-1.4.6-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.