Bug 70110 - xmlto chokes on files with underscore in their name
xmlto chokes on files with underscore in their name
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xmlto (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 10:40 EDT by Crutcher Dunnavant
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 18:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for /usr/share/xmlto/format/fo/* (2.85 KB, patch)
2002-08-02 04:56 EDT, Crutcher Dunnavant
no flags Details | Diff

  None (edit)
Description Crutcher Dunnavant 2002-07-30 10:40:46 EDT
Description of Problem:
xmlto will fail on processing files with underscores in their names.

Version-Release number of selected component (if applicable):
xmlto-0.0.8, xmlto-0.0.10-4 (the limbo beta)

How Reproducible:
use xmlto on the attached file as:

xmlto ps example.xml

and as

xmlto ps example_underscore.xml


This is very annoying/broken. I'm trying to find the cause, but haven't found it
yet.
Comment 1 Tim Waugh 2002-07-30 18:55:07 EDT
This is a tetex limitation of some sort.  It might be worthwhile for xmlto to 
work around it though.
Comment 2 Crutcher Dunnavant 2002-07-31 03:24:35 EDT
I'm faking it like this in my makefiles, if it helps:

%.ps: %.fo
        # Stupid, stupid, stupid xmltex dies on '_' in filenames.
        ORIGDIR="$$PWD"; \
        DIR=`mktemp -d /tmp/ghede.XXXXXX`; \
        MUNGE=`basename $^ | sed -e 's/_/.u./g'`; \
        cp $^ $$DIR/$$MUNGE.fo && \
        cd $$DIR; \
        xmltex $$MUNGE.fo > /dev/null && \
        xmltex $$MUNGE.fo > /dev/null && \
        xmltex $$MUNGE.fo > /dev/null && \
        dvips -R -q -o $$ORIGDIR/$@ $$MUNGE.dvi; \
        cd $$ORIGDIR; \
        rm -rf $$DIR;

%.pdf: %.fo
        # Stupid, stupid, stupid pdfxmltex dies on '_' in filenames.
        ORIGDIR="$$PWD"; \
        DIR=`mktemp -d /tmp/ghede.XXXXXX`; \
        MUNGE=`basename $^ | sed -e 's/_/.u./g'`; \
        cp $^ $$DIR/$$MUNGE.fo && \
        cd $$DIR; \
        pdfxmltex $$MUNGE.fo > /dev/null && \
        pdfxmltex $$MUNGE.fo > /dev/null && \
        pdfxmltex $$MUNGE.fo > /dev/null && \
        mv $$MUNGE.pdf $$ORIGDIR/$@; \
        cd $$ORIGDIR; \
        rm -rf $$DIR;
Comment 3 Crutcher Dunnavant 2002-08-02 04:56:31 EDT
Created attachment 68426 [details]
patch for /usr/share/xmlto/format/fo/*
Comment 4 Tim Waugh 2002-08-05 18:43:51 EDT
Fixed in CVS.
Comment 5 Tim Waugh 2002-10-16 12:55:31 EDT
Fixed package is xmlto-0.0.11-1.

Note You need to log in before you can comment on or make changes to this bug.