Bug 70113 - traceback when / doesn't have enough space
Summary: traceback when / doesn't have enough space
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-30 15:19 UTC by Brock Organ
Modified: 2007-04-18 16:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-04 18:16:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Limbo2 Anaconda traceback/dump with 70MB / partition (79.39 KB, text/plain)
2002-08-08 10:37 UTC, Barry K. Nathan
no flags Details

Description Brock Organ 2002-07-30 15:19:00 UTC
* tested with Limbo-re0726.1 test tree
* Everything install on a / partition with not enough space

a traceback occurs:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 757, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 610, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 681, in doInstall
    os.unlink("/mnt/sysimage/var/tmp")
OSError: [Errno 21] Is a directory: '/mnt/sysimage/var/tmp'

Local variables in innermost frame:
intf: <gui.InstallInterface instance at 0x861b0dc>
modeText: Installing %s-%s-%s.

instPath: /mnt/sysimage
syslogname: /mnt/sysimage/root/install.log.syslog
db: <rpmdb object at 0xa875560>
totalSize: 4872292
problems: [('installing package mrtg-2.9.17-8 needs 4Mb on the /mnt/sysimage
filesystem',
...

Comment 1 Tim Waugh 2002-08-07 12:16:18 UTC
I also saw this while upgrading.

Comment 2 Tim Waugh 2002-08-07 12:17:09 UTC
(on i686)

Comment 3 Barry K. Nathan 2002-08-08 10:37:47 UTC
Created attachment 69504 [details]
Limbo2 Anaconda traceback/dump with 70MB / partition

Comment 4 Barry K. Nathan 2002-08-08 10:49:26 UTC
I've also seen this. BTW, this was a Minimal install with a 70MB /, 590MB or so
/usr, and 3.2GB /home. This may sound insane, but it's a partition layout copied
from a real machine, and Red Hat 7.3 can (just barely) install and run on this.

If there were any earlier size checks, they didn't catch this before the
traceback... (This was an NFS image install, FWIW.)

Comment 5 Jeremy Katz 2002-08-13 04:30:14 UTC
The traceback was due to a last minute error checking code path that wasn't
quite right.  Fixed in CVS.  You won't hit it in Limbo as long as you make sure
to have enough free space before going to install packages

Comment 6 David Lawrence 2002-09-04 17:30:20 UTC
Verified that a traceback does not occur with latest code. But a loop condition
is created. If not enough space on / it will tell you, once you hit OK it will
allow the install to continue. It then formats / and whatever other parts you
created, then appears to start installing. The it comes back again with you do
not have enough space on /. When you hit OK the whole process starts over. Is
this expected?

Comment 7 Jeremy Katz 2002-09-04 18:16:26 UTC
Yes -- you have to go back to the package selection screen and change your
package selection if you want to have anything else to occur


Note You need to log in before you can comment on or make changes to this bug.