Bug 701181 - bluedevil drags in pulseaudio through dependencies
bluedevil drags in pulseaudio through dependencies
Status: CLOSED DUPLICATE of bug 700155
Product: Fedora
Classification: Fedora
Component: bluedevil (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-01 17:59 EDT by Orcan Ogetbil
Modified: 2011-05-01 20:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-01 20:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2011-05-01 17:59:46 EDT
Description of problem:
bluedevil depends directly on pulseaudio-module-bluetooth, which drags in pulseaudio.

Is it possible to split the pulseaudio dependency to a subpackage? Fedora works beautifully without pulseaudio as it always did. Given that there is a significant fraction of people which still don't use pulseaudio, dictating its installation does not seem like a legitimate solution.

If splitting is not possible, could you suggest an alternative solution?

Thanks.


Version-Release number of selected component (if applicable):
1.1-1.fc14

How reproducible:
always

Steps to Reproduce:
1. Update a Fedora 14 KDE installation.
2. pulseaudio gets dragged in.
3.
  
Actual results:
pulseaudio

Expected results:
workingaudio

Additional info:
Everything worked fine until the 1.1-1.fc14 update.
Comment 1 Kevin Kofler 2011-05-01 18:26:54 EDT

*** This bug has been marked as a duplicate of bug 700155 ***
Comment 2 Orcan Ogetbil 2011-05-01 18:42:04 EDT
Well, not quite.

The marked bug does is closed and it does not contain answers to all the questions I asked.
Comment 3 Kevin Kofler 2011-05-01 18:56:21 EDT
The bug is exactly about the same thing as yours => duplicate.

*** This bug has been marked as a duplicate of bug 700155 ***
Comment 4 Orcan Ogetbil 2011-05-01 20:00:10 EDT
Please prove me wrong:


(In reply to comment #3)
> The bug is exactly about the same thing as yours => duplicate.

No, that's not true. Let's analyze:

From the bug that you referred:


> The package bluedevil requires pulseaudio-module-bluetooth, which requires
> pulseaudio.
> There are still users that do not want pulseaudio.
> bluedevil does not really need pulseaudio-module-bluetooth.
> I guess the dependency has been added to be convenient, but it is a mess for
> non-pulseaudio users.
> 
> Please, remove this dependancy.


The author of this message asks you to remove the pulseaudio dependency. And this is all.

Let's have a look at my message:

(In reply to comment #0)
> Is it possible to split the pulseaudio dependency to a subpackage? Fedora works
> beautifully without pulseaudio as it always did. Given that there is a
> significant fraction of people which still don't use pulseaudio, dictating its
> installation does not seem like a legitimate solution.
> 
> If splitting is not possible, could you suggest an alternative solution?
> 

The author of this message does not say he wants you to remove this dependency.

He clearly asks two questions:

- Is it possible to split the pulseaudio dependency to a subpackage?
- If splitting is not possible, could you suggest an alternative solution?

These two questions does not exist in the bug you mentioned.

Hence the two bug reports are different.

Reopening.
Comment 5 Kevin Kofler 2011-05-01 20:20:17 EDT
> - Is it possible to split the pulseaudio dependency to a subpackage?

Already asked by the other submitter:
https://bugzilla.redhat.com/show_bug.cgi?id=700155#c2

> - If splitting is not possible, could you suggest an alternative solution?

No.

Now your questions are answered, stop reopening the bug.

*** This bug has been marked as a duplicate of bug 700155 ***
Comment 6 Orcan Ogetbil 2011-05-01 20:48:49 EDT
(In reply to comment #5)
> > - Is it possible to split the pulseaudio dependency to a subpackage?
> 
> Already asked by the other submitter:
> https://bugzilla.redhat.com/show_bug.cgi?id=700155#c2
> 

No, the other submitter, talks about an empty metapackage. I am talking about a subpackage with split functionality.


Different questions. Different requests.

> > - If splitting is not possible, could you suggest an alternative solution?
> 
> No.
> 

Thanks. But the question did not exist in the bug you mentioned.

Hence this is not duplicate.

Reopening.
Comment 7 Kevin Kofler 2011-05-01 20:53:17 EDT
Same complaint, different suggested resolutions. Post your suggestions to the original bug if you think they're relevant. (As explained on IRC, I actually think they don't make sense.) Reopening this one is not helpful.

*** This bug has been marked as a duplicate of bug 700155 ***

Note You need to log in before you can comment on or make changes to this bug.