Bug 701203 - [abrt] ibus-1.3.99.20110408-2.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us:dvorak.
[abrt] ibus-1.3.99.20110408-2.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:0670eef98cc6ca866bff0445b02...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-01 23:25 EDT by Angus Salkeld
Modified: 2014-01-12 20:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-10 02:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.27 KB, text/plain)
2011-05-01 23:25 EDT, Angus Salkeld
no flags Details

  None (edit)
Description Angus Salkeld 2011-05-01 23:25:53 EDT
abrt version: 2.0.1
comment: i am having trouble changing to and from different input methods
package: ibus-1.3.99.20110408-2.fc15
cmdline: /usr/bin/python /usr/share/ibus/ui/gtk/main.py
executable: /usr/share/ibus/ui/gtk/main.py
component: ibus
architecture: x86_64
kernel: 2.6.38.3-18.fc15.x86_64
reason: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us:dvorak.
uid: 500
username: asalkeld
os_release: Fedora release 15 (Lovelock)
time: 1304306534

backtrace
-----
connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us:dvorak.

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 526, in __im_menu_item_activate_cb
    self.__focus_ic.set_engine(engine)
  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in set_engine
    return self.__context.SetEngine(engine.name)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to xkb:layout:us:dvorak.

Local variables in innermost frame:
byte_arrays: False
self: <dbus.connection.Connection object at 0x134f110>
args: (dbus.String(u'xkb:layout:us:dvorak'),)
utf8_strings: False
bus_name: 'org.freedesktop.IBus'
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_17')
timeout: -1.0
signature: u's'
dbus_interface: 'org.freedesktop.IBus.InputContext'
message: <dbus.lowlevel.MethodCallMessage object at 0x127da08>
method: 'SetEngine'
Comment 1 Angus Salkeld 2011-05-01 23:25:56 EDT
Created attachment 496157 [details]
File: backtrace
Comment 2 fujiwara 2011-05-09 05:25:35 EDT
I cannot reproduce this bug.
Are you able to reproduce your issue with the fix of bug 701202 ?

(In reply to comment #0)
>   File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in
> call_blocking
>     message, timeout)
> DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
> focus can not change engine to xkb:layout:us:dvorak.
> 

How did you lose the input focus?
Comment 3 Angus Salkeld 2011-05-09 07:06:02 EDT
(In reply to comment #2)
> I cannot reproduce this bug.
> Are you able to reproduce your issue with the fix of bug 701202 ?
> 
> (In reply to comment #0)
> >   File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in
> > call_blocking
> >     message, timeout)
> > DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has
> > focus can not change engine to xkb:layout:us:dvorak.
> > 
> 
> How did you lose the input focus?

I honestly don't know?

All I was doing at the time was changing between layouts 
english-us and english-dvorak-us. This was very reproducible
but now I can't seem to make it happen.
Comment 4 fujiwara 2011-05-10 02:42:51 EDT
If you can reproduce this bug, please comment here again. Thanks.

Note You need to log in before you can comment on or make changes to this bug.