Bug 701220 - iSCSI login dialog allows unselecting all devices and continuing - unable to login to any iSCSI devices after
iSCSI login dialog allows unselecting all devices and continuing - unable to ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ales Kozumplik
Release Test Team
patch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-02 03:04 EDT by Ales Kozumplik
Modified: 2014-09-30 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.21.118-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 700085
Environment:
Last Closed: 2011-12-06 05:32:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed iscsi login screen (42.44 KB, image/png)
2011-08-08 08:07 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Ales Kozumplik 2011-05-02 03:04:03 EDT
+++ This bug was initially created as a clone of Bug #700085 +++

Created attachment 495211 [details]
anaconda-logs.tgz (/tmp/*log /tmp/anaconda-screenshots)

Description of problem:

While adding an iSCSI device, if you forget to select any of the discovered iSCSI devices (or uncheck all of them), you can still click the "Login" button.  After that, you are unable to login to any iSCSI devices.

Version-Release number of selected component (if applicable):
 * anaconda-15.29-1

How reproducible:
 * pretty easy, and happens every time when entering incorrect data.

Steps to Reproduce:
1. Follow steps outlined at https://fedoraproject.org/wiki/QA:Testcase_Anaconda_ISCSI_No_Authentication
2. After iSCSI discovery finds available volumes, unselect all volumes and click 'Login'
  
Actual results:

THe user is able to click 'Login' and the dialog closes.  From that point, any attempts to re-add an iSCSI device fail.

Expected results:

The 'Login' button should be deactivated (unclickable) if no devices are selected.

Additional info:

* Nominating for a F15 nice-to-have fix since I suspect this won't be a disruptive change.
* See attached log files ...

-rw-r--r-- root/root     27432 2011-04-27 08:16 tmp/X.log
-rw-r--r-- root/root      4620 2011-04-27 08:18 tmp/anaconda.log
-rw-r--r-- root/root      2380 2011-04-27 08:17 tmp/ifcfg.log
-rw-r--r-- root/root      2425 2011-04-27 08:17 tmp/program.log
-rw-r--r-- root/root      5150 2011-04-27 08:17 tmp/storage.log
-rw-r--r-- root/root     55541 2011-04-27 08:18 tmp/syslog
-rw-r--r-- root/root     68515 2011-04-27 08:18 tmp/anaconda-screenshots/screenshot-0001.png

^^^ The error dialog

-rw-r--r-- root/root     72580 2011-04-27 08:17 tmp/anaconda-screenshots/screenshot-0000.png

^^^ Demonstrating deselecting all iSCSI devices
Comment 1 Ales Kozumplik 2011-05-02 03:04:50 EDT
Patch is ready: 5ac783808cb015ea67006833fa8f9ef3fcbd350e.
Comment 2 James Laska 2011-05-02 07:55:00 EDT
Removing Fedora dependencies
Comment 3 Adam Williamson 2011-05-06 19:35:14 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 RHEL Product and Program Management 2011-05-13 19:08:04 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 5 Ales Kozumplik 2011-06-10 04:28:39 EDT
Fixed by 93b4d8aebb7bb45e0fce8f3b9b2fdaa199944246.
Comment 7 Alexander Todorov 2011-08-08 08:07:51 EDT
Created attachment 517191 [details]
fixed iscsi login screen

In anaconda-13.21.126 if no iSCSI targets are selected the Login button is disabled. See screenshot.
Comment 8 errata-xmlrpc 2011-12-06 05:32:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html

Note You need to log in before you can comment on or make changes to this bug.