Bug 701449 - Done, but with errors
Done, but with errors
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
3.0.0
x86_64 Windows
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-02 17:19 EDT by sara.a.stewart
Modified: 2014-05-09 12:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 12:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sara.a.stewart 2011-05-02 17:19:21 EDT
Description of problem:
Bringing up the RHQ GUI in IE8 produces the following errors:
Message: Exception thrown and not caught
Line: 185
Char: 34
Code: 0
URI: https://<machine name>/a4j/g/3_3_3.CR1org/richfaces/renderkit/html/scripts/jquery/jquery.js.xhtml


Message: Object doesn't support this property or method
Line: 46
Char: 2
Code: 0
URI: https://<machine name>/js/pngfix.js


Version-Release number of selected component (if applicable):
3.0.0


How reproducible:
Every time

Steps to Reproduce:
1)  In IE8, go to the rhq URL (will vary depending on the machine)
2)  Enter the username/password for rhq
3)  The error should happen right away b/c it seems to be tied to the dashboard tab.  
4)  Look at the very bottom left hand corner of the web browser.
5)  You should see a yellow warning triangle with the message “Done, but with errors on the page”
6)  Click (double click) on the yellow warning triangle.
 
Actual results:
Message: Exception thrown and not caught
Line: 185
Char: 34
Code: 0
URI: https://<machine name>/a4j/g/3_3_3.CR1org/richfaces/renderkit/html/scripts/jquery/jquery.js.xhtml


Message: Object doesn't support this property or method
Line: 46
Char: 2
Code: 0
URI: https://<machine name>/js/pngfix.js

Expected results:
Webpage should not have errors.  Should say Done.

Additional info:
It looks like this error is tied into code that was supposed to fix images with png extensions for IE7 or early versions, but somehow breaks in IE8.
Comment 1 Jay Shaughnessy 2014-05-09 12:04:14 EDT
WebServices are no longer supported.

Note You need to log in before you can comment on or make changes to this bug.