Bug 701513 - [abrt] yelp-3.0.2-1.fc15: yelp_window_load_uri: Process /usr/bin/yelp was killed by signal 11 (SIGSEGV)
[abrt] yelp-3.0.2-1.fc15: yelp_window_load_uri: Process /usr/bin/yelp was kil...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:f7b17217c6a39ae840483c78df8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-02 23:56 EDT by Bryan Quigley
Modified: 2011-06-22 12:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 12:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (2.32 KB, text/plain)
2011-05-02 23:56 EDT, Bryan Quigley
no flags Details
File: build_ids (3.92 KB, text/plain)
2011-05-02 23:56 EDT, Bryan Quigley
no flags Details
File: dsos (20.34 KB, text/plain)
2011-05-02 23:56 EDT, Bryan Quigley
no flags Details
File: maps (23.01 KB, text/plain)
2011-05-02 23:56 EDT, Bryan Quigley
no flags Details
File: backtrace (25.98 KB, text/plain)
2011-05-02 23:56 EDT, Bryan Quigley
no flags Details

  None (edit)
Description Bryan Quigley 2011-05-02 23:56:11 EDT
abrt version: 2.0.1
comment: Retesting to see if the bug was still present.  It was fixed by adding the gnome-games-help package.  However I suppose it should fail more gracefully.. but that's up to you.
executable: /usr/bin/yelp
cmdline: yelp ghelp:aisleriot
component: yelp
uid: 500
crash_function: yelp_window_load_uri
kernel: 2.6.38.3-18.fc15.i686
reason: Process /usr/bin/yelp was killed by signal 11 (SIGSEGV)
architecture: i686
username: bryan
package: yelp-3.0.2-1.fc15
os_release: Fedora release 15 (Lovelock)
time: 1304394564
rating: 4

Text file: event_log, 2371 bytes
Text file: build_ids, 4018 bytes
Binary file: coredump, 63635456 bytes
Text file: dsos, 20832 bytes
Text file: maps, 23562 bytes
Text file: backtrace, 26607 bytes

environ
-----
XDG_SESSION_ID=1
HOSTNAME=bryan-fedora.home
IMSETTINGS_INTEGRATE_DESKTOP=yes
SHELL=/bin/bash
TERM=dumb
HISTSIZE=1000
XDG_SESSION_COOKIE=6dd38f83674e6bae2cb8ce230000000d-1304392700.421181-1754976591
GNOME_KEYRING_CONTROL=/tmp/keyring-dn0vIo
IMSETTINGS_MODULE=none
USER=bryan
USERNAME=bryan
MAIL=/var/spool/mail/bryan
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/bryan/bin
DESKTOP_SESSION=gnome
QT_IM_MODULE=xim
PWD=/home/bryan
XMODIFIERS=@im=none
GNOME_KEYRING_PID=1359
LANG=en_US.UTF-8
GDM_LANG=
GDMSESSION=gnome
HISTCONTROL=ignoredups
HOME=/home/bryan
SHLVL=1
LOGNAME=bryan
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-jpnRrYGDWz,guid=25f6507315f50697b0cd942500000034
'LESSOPEN=||/usr/bin/lesspipe.sh %s'
WINDOWPATH=1
XDG_RUNTIME_DIR=/run/user/bryan
DISPLAY=:0.0
GTK_IM_MODULE=gtk-im-context-simple
G_BROKEN_FILENAMES=1
XAUTHORITY=/var/run/gdm/auth-for-bryan-yyXr7a/database
_=/usr/bin/gnome-session
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1367,unix/unix:/tmp/.ICE-unix/1367
ORBIT_SOCKETDIR=/tmp/orbit-bryan
GPG_AGENT_INFO=/tmp/keyring-dn0vIo/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-dn0vIo/ssh
GJS_DEBUG_OUTPUT=stderr
'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-yelp.desktop
GIO_LAUNCHED_DESKTOP_FILE_PID=2117
DESKTOP_STARTUP_ID=sol-2113-bryan-fedora.home-yelp-0_TIME1909181
Comment 1 Bryan Quigley 2011-05-02 23:56:13 EDT
Created attachment 496418 [details]
File: event_log
Comment 2 Bryan Quigley 2011-05-02 23:56:15 EDT
Created attachment 496419 [details]
File: build_ids
Comment 3 Bryan Quigley 2011-05-02 23:56:17 EDT
Created attachment 496420 [details]
File: dsos
Comment 4 Bryan Quigley 2011-05-02 23:56:19 EDT
Created attachment 496421 [details]
File: maps
Comment 5 Bryan Quigley 2011-05-02 23:56:22 EDT
Created attachment 496422 [details]
File: backtrace
Comment 6 Bryan Quigley 2011-05-03 00:02:16 EDT
I originally thought this was a duplicate of BUG697372, but ABRT told me otherwise.
Comment 7 Kjartan Maraas 2011-05-09 07:51:48 EDT
Package: yelp-3.0.2-3.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I hit f1 to open help, then closed yelp and did the same again.
Comment 8 Jhonny Oliveira 2011-05-29 02:28:20 EDT
Package: yelp-3.0.3-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
opening it, right after closing
Comment 9 Bryan Quigley 2011-06-22 12:11:11 EDT
This appears to have been fixed.  It now displays an error message (in somewhat technical terms) detailing how the file it is looking for is not there.  Which is clearly better than crashing.

Note You need to log in before you can comment on or make changes to this bug.