Bug 701653 - Can't install ADT for eclipse
Can't install ADT for eclipse
Status: CLOSED DUPLICATE of bug 698434
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-03 09:45 EDT by ywcai
Modified: 2011-05-14 22:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-05 19:04:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ywcai 2011-05-03 09:45:46 EDT
Description of problem:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Android Development Tools 10.0.1.v201103111512-110841 (com.android.ide.eclipse.adt.feature.group 10.0.1.v201103111512-110841)
  Missing requirement: Android Development Tools 10.0.1.v201103111512-110841 (com.android.ide.eclipse.adt.feature.group 10.0.1.v201103111512-110841) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found

Version-Release number of selected component (if applicable):
EClipse 3.6.1 in Fedora 15 Beta

How reproducible:
EClipse about->install new software->select site "http://dl-ssl.google.com/android/eclipse/" or "https://dl-ssl.google.com/android/eclipse/"->check all items->update

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Android Development Tools 10.0.1.v201103111512-110841 (com.android.ide.eclipse.adt.feature.group 10.0.1.v201103111512-110841)
  Missing requirement: Android Development Tools 10.0.1.v201103111512-110841 (com.android.ide.eclipse.adt.feature.group 10.0.1.v201103111512-110841) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found

Expected results:
Can install ADT successfully

Additional info:
Comment 1 Severin Gehwolf 2011-05-03 10:05:59 EDT
Could you please update to 3.6.2-5 as described in bug 698434. This should fix your problem. Thanks!

*** This bug has been marked as a duplicate of bug 698434 ***
Comment 2 ywcai 2011-05-04 10:11:44 EDT
Hi, I have update eclipse-3.6.2-5.fc15, sat4j-2.3.0-2.fc15 and some other eclipse-3.6.2-... packages, but still:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Android Development Tools 10.0.1.v201103111512-110841 (com.android.ide.eclipse.adt.feature.group 10.0.1.v201103111512-110841)
  Missing requirement: Android Development Tools 10.0.1.v201103111512-110841 (com.android.ide.eclipse.adt.feature.group 10.0.1.v201103111512-110841) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found
Comment 3 Alexander Kurtakov 2011-05-04 10:18:38 EDT
Can you verify that you have helios update site enabled?
Comment 4 ywcai 2011-05-05 19:04:50 EDT
Yes, the helios site is enabled.

Found the solution:
uninstall preloaded eclipse, remove workspace, then download helios & gef packages from eclipse.org, unzip helios, then install gef from "Install new software" menu, then install ADT

*** This bug has been marked as a duplicate of bug 698434 ***
Comment 5 Andrew Overholt 2011-05-06 10:09:41 EDT
Using an upstream binary doesn't solve the problem for the Fedora packages.
Comment 6 ywcai 2011-05-14 22:43:59 EDT
Yes, to solve the issue, only need enable helios update site at the same time when installing ADT.

I have verified the solution.

Note You need to log in before you can comment on or make changes to this bug.