Bug 701849 - [abrt] libreoffice-calc-1: Font::Font(Font const&): Process /usr/lib/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-calc-1: Font::Font(Font const&): Process /u...
Status: CLOSED DUPLICATE of bug 658304
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-05-03 23:37 EDT by Tomas Dabašinskas
Modified: 2011-05-04 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-05-03 23:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (32.68 KB, text/plain)
2011-05-03 23:37 EDT, Tomas Dabašinskas
no flags Details

  None (edit)
Description Tomas Dabašinskas 2011-05-03 23:37:43 EDT
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 33460 bytes
cmdline: /usr/lib/libreoffice/program/scalc.bin -calc
component: libreoffice
Attached file: coredump, 67940352 bytes
crash_function: Font::Font(Font const&)
executable: /usr/lib/libreoffice/program/scalc.bin
package: libreoffice-calc-1:
rating: 3
reason: Process /usr/lib/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1304480180
uid: 500

Simply started office calc, tried opening file same problem, when running from command line:

$ soffice -calc
/usr/bin/soffice: line 163:  1871 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"

How to reproduce
Office calc fails to start (was working before)

1. Tried running office calc
Comment 1 Tomas Dabašinskas 2011-05-03 23:37:46 EDT
Created attachment 496680 [details]
File: backtrace
Comment 2 Tomas Dabašinskas 2011-05-03 23:48:21 EDT
deleted ~/.libreoffice, works now
Comment 3 David Tardon 2011-05-04 04:46:46 EDT
My bad, I forgot to add the patch fixing this crash into libreoffice 3.3 as well. It will be okay in libreoffice- .

*** This bug has been marked as a duplicate of bug 658304 ***

Note You need to log in before you can comment on or make changes to this bug.