Bug 70186 - Installer fails to start X11 or VESA
Installer fails to start X11 or VESA
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On: 70190
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 19:01 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-26 15:55:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from "lspci -vv" (7.59 KB, text/plain)
2002-08-06 16:05 EDT, Need Real Name
no flags Details
output from "lspci -vvn" (6.74 KB, text/plain)
2002-08-06 16:05 EDT, Need Real Name
no flags Details
[installer] failed start of graphical installer -> X.log (1.20 KB, text/plain)
2002-08-06 16:07 EDT, Need Real Name
no flags Details
[installer] failed start of graphical installer -> XF86Config used at installation time (3.75 KB, text/plain)
2002-08-06 16:08 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-30 19:01:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Cannot use graphic Installer 'cause anaconda cannot start X11 or VESA at
Installation Time. Even if anaconda detected my graphic card (nvidia geforce 2
mmx) and monitor (belinea 106020) correct.

This applies to RedHat Linux 7.3 (Valhalla) through 7.3.93 (Limbo) -- other ones
arent tested.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat Linux with bootable CDROM
2.select new installation
3.dont select any special in menus, only accepting defaults
	

Actual Results:  start of graphical installer with X11 and VESA fails

must use text installer instead

Expected Results:  X11 should have been started because both monitor and graphic
adapter were detected correctly.

Additional info:
Comment 1 Michael Fulbright 2002-08-02 14:23:14 EDT
Mike are you familiar with problems with this chipset?
Comment 2 Mike A. Harris 2002-08-05 19:14:15 EDT
Nothing that comes to mind.  In order to fathom a guess though, I'll need
a copy of the X config file, and X server log from a failed XFree86
start attempt.

I also need the output of "lspci -vvn" and "lspci -vv"
Comment 3 Steve Scheuber 2002-08-06 09:21:04 EDT
In answer to the question about Xconfigurator... YES, I've tried multiple times 
to use Xconfigurator -- with no luck.  Just this morning, I tried installing 
6.0 from scratch and had no problems.  Everything works fine -- including X.  
Since I've installed 6.0, I no longer have the requested files "X config file, 
and X server log from a failed XFree86"

In order to help track this down, I will re-install 7.2 from CD and collect the 
requested information, along with output of "lspci -vvn" and "lspci -vv" 
commands.  Thanks.
Comment 4 Steve Scheuber 2002-08-06 09:34:15 EDT
I forgot one more bit of potentially related detail:  When installing 6.1 (I 
earlier said 6.0 by mistake) I was promted for my monitor settings 8 bit color, 
16 bit color, 32 bit color (with a variety of screen sizes to select from).  
Upon selecting ANY 8 bit or 16 bit options, and pressing the TEST button, I got 
what I expected to be the desired behaviour -- the system would attempt the 
specified settings and return to the configuration window 100% of the time 
(regardless of whether it worked or not).  Attempting this with the 7.2 install 
led to much different results.  About 80% of the time, the system would test 
the specified settings (without luck) -- leading to a totally black screen -- 
and WOULD NOT return to the configuration window.  The only option I knew of 
led me to a power cycle and starting the installation over.
Comment 5 Need Real Name 2002-08-06 16:05:21 EDT
Created attachment 69165 [details]
output from "lspci -vv"
Comment 6 Need Real Name 2002-08-06 16:05:59 EDT
Created attachment 69166 [details]
output from "lspci -vvn"
Comment 7 Need Real Name 2002-08-06 16:07:49 EDT
Created attachment 69167 [details]
[installer] failed start of graphical installer -> X.log
Comment 8 Need Real Name 2002-08-06 16:08:40 EDT
Created attachment 69168 [details]
[installer] failed start of graphical installer -> XF86Config used at installation time
Comment 9 Need Real Name 2002-08-06 16:15:09 EDT
Oh....look at this bloody mess in XF86Config.test used at installation time:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync   -268377405--268374161
        VertRefresh -268374161--268370092
        Option "dpms"
        DisplaySize    270.933333333 203.2
EndSection

The same insane HorizSync/VertRefresh values i reported as bug 70190 !
For a Belinea Monitor the correct values are

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync    30-96
        VertRefresh  50-160
        Option "dpms"
EndSection
Comment 10 Mike A. Harris 2002-11-03 06:54:47 EST
The last comment looks like anaconda is generating a bogus config.  If this
is indeed the case, there's nothing we can do about anaconda for an already
released distro.

Do a text mode install or whatever, and after install, run Xconfigurator
by hand.  Does this result in a working config?

Also, have you tried using Red Hat Linux 8.0?  It would be interesting to
know if you have the same problem in 8.0 or not.
Comment 11 Mike A. Harris 2002-11-10 23:39:15 EST
Reassigning to anaconda component.
Comment 12 Need Real Name 2002-11-28 18:01:03 EST
> The last comment looks like anaconda is generating a bogus config.  If this
> is indeed the case, there's nothing we can do about anaconda for an already
> released distro.
problem was discovered by me in latest Red Hat Linux 7.3.9x; Red Hat 8.0 has
this bug solved

> Also, have you tried using Red Hat Linux 8.0?  It would be interesting to
> know if you have the same problem in 8.0 or not.
today i installed Red Hat Linux 8.0 and yes the installer works with graphics
and also the auto-generated X11 config file is correct and sane

problem solved.

one last:
please add the monitor "maxdata belinea 106035" in your monitor database
(HorizSync: 30...96 kHz and VertRefresh: 50...160 Hz )

Note You need to log in before you can comment on or make changes to this bug.