Bug 70203 - YMF704C-S sound chip is given wrong module
YMF704C-S sound chip is given wrong module
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 21:30 EDT by Jim Prior
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 17:56:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Prior 2002-07-30 21:30:22 EDT
Description of Problem:

   no sound
   installer chose wrong module for YMF704C-S sound chip.  
   It chose ad1848 module instead of opl3sa2 module.  

Version-Release number of selected component (if applicable):


How Reproducible:

   do not know

Steps to Reproduce:
1. Install RH 7.3 Workstation with mostly defaults; default console login
2. Get a known good .mp3 file.  
3. Try to play that file with mpg123.  It won't work.  

Actual Results:

   mpg123 fails and their is silence

Expected Results:

   sound

Additional Information:

   I figured out how to get it working.  	
   The offending line is /etc/modules.conf was: 

      alias sound-slot-0 ad1848

   When I changed it to: 

      alias sound-slot-0 opl3sa2

   then sound works.  
   (The first time I try mpg123 after booting, it fails, 
   but subsequent tries work just fine.)

   Previous RH 7.2 installation worked just fine without me having 
   to modify /etc/modules.conf.  That's where I got the clue from 
   its old /etc/modules.conf for how to fix the new RH 7.3 installation.  

   On my RH 7.3, there are two interesting sections in /etc/sysconfig/hwconf:

      -
      class: UNSPEC
      bus: ISAPNP
      detached: 0
      driver: ns558
      desc: "YAMAHA OPL3-SAx Audio System:Unknown"
      deviceId: YMH0022
      pdeviceId: YMH0802
      compat: PNPb02f
      native: 1
      active: 0
      cardnum: 0
      logdev: 1
      dma: 0,0

   and later: 

      -
      class: AUDIO
      bus: ISAPNP
      detached: 0
      driver: ad1848
      desc: "YAMAHA OPL3-SAx Audio System:Unknown"
      deviceId: YMH0021
      pdeviceId: YMH0802
      native: 1
      active: 0
      cardnum: 0
      logdev: 0
      dma: 0,0

   $ cat devices
   0100    YMH0802YMH0021 
0102400e80038803000100000000000000050200020103030000000000000000000000000000000000
   0101    YMH0802YMH0022 
0000000000000000000000000000000000000000000000000000000000000000000000000000000000
Comment 1 Jim Prior 2002-07-30 23:43:56 EDT
The problem is repeatable with kudzu.

I chopped out the YAMAHA stuff from /etc/sysconfig/hwconf and ran kudzu.
Kudzu detected the YAMAHA sound stuff
and put the (wrong) ad1848 module back in /etc/modules.conf.

# cd /etc
# cp modules.conf modules.conf.good
# cd /etc/sysconfig
# cp hwconf hwconf.before
# vi hwconf
# diff /etc/sysconfig/hwconf.before /etc/sysconfig/hwconf
2,15d1
< class: UNSPEC
< bus: ISAPNP
< detached: 0
< driver: ns558
< desc: "YAMAHA OPL3-SAx Audio System:Unknown"
< deviceId: YMH0022
< pdeviceId: YMH0802
< compat: PNPb02f
< native: 1
< active: 0
< cardnum: 0
< logdev: 1
< dma: 0,0
< -
119,133d104
< -
< class: AUDIO
< bus: ISAPNP
< detached: 0
< driver: ad1848
< desc: "YAMAHA OPL3-SAx Audio System:Unknown"
< deviceId: YMH0021
< pdeviceId: YMH0802
< native: 1
< active: 1
< cardnum: 0
< logdev: 0
< io: 0x240,0xe80,0x388,0x300,0x100
< irq: 5
< dma: 1,3
# kudzu
[kudzu said: The following sound card has been added to your system
YAMAHA OPL3-SAx Audio System:Unknown
I "configured" it]
# diff /etc/modules.conf.good /etc/modules.conf
5c5
< alias sound-slot-0 opl3sa2
---
> alias sound-slot-0 ad1848
7d6
< post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
#
Comment 2 Bill Nottingham 2005-02-04 17:56:09 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.

Note You need to log in before you can comment on or make changes to this bug.