Bug 70208 - gcc internal compiler error when compiling transcode
Summary: gcc internal compiler error when compiling transcode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-31 02:40 UTC by Florin Andrei
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 00:10:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the full typescript file with the error (deleted)
2002-07-31 02:42 UTC, Florin Andrei
no flags Details

Description Florin Andrei 2002-07-31 02:40:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
My RH 7.3 has all available (July 30th) updates applied.
When compiling transcode-0.6.0rc4 (released today), gcc dies with an internal
error. Older transcode releases compile fine.
I've been told that gcc-3.1 also has the exact same problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile transcode-0.6.0rc4
2.
3.
	

Actual Results:  gcc crashed

Expected Results:  transcode should compile fine

Additional info:

You can download transcode-0.6.0rc4 from here:
http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/
This is the error that i get:
######################################################
gcc -DHAVE_CONFIG_H -I../.. -I. -I../.. -I. -Wall -I./ -I../.. -I../../src/
-I./../.. -I./../../src -I../../libvo -D_REENTRANT -march=athlon -O3
-fomit-frame-pointer -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-D_FILE_OFFSET_BITS=64 -c motion.c -MT motion.lo -MD -MP -MF .deps/motion.TPlo 
-fPIC -DPIC -o motion.lo
motion.c: In function `calc_SAD_half_mmx':
motion.c:640: Internal compiler error in fixup_var_refs_1, at function.c:1874
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [motion.lo] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/transcode-0.6.0rc4/filter/yuvdenoise'
######################################################
After submitting this bug report i'll attach the full typescript file to it.

Comment 1 Florin Andrei 2002-07-31 02:45:17 UTC
Well, i cannot attach the typescript file because your Oracle DB barfed at me. :-)

Comment 2 Richard Henderson 2004-10-03 00:10:21 UTC
Build succeeds with gcc 3.2.3-20 and transcode 0.6.12.


Note You need to log in before you can comment on or make changes to this bug.