Bug 70211 - Firstboot never appears after installation
Firstboot never appears after installation
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-30 23:13 EDT by Marc Deslauriers
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 21:02:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is /var/log/messages (deleted)
2002-07-30 23:13 EDT, Marc Deslauriers
no flags Details
Here is /var/log/messages (deleted)
2002-07-30 23:14 EDT, Marc Deslauriers
no flags Details
XFree log file (deleted)
2002-07-30 23:14 EDT, Marc Deslauriers
no flags Details
Well try this one again... (deleted)
2002-07-30 23:15 EDT, Marc Deslauriers
no flags Details
Another try at the /var/log/messages file (23.22 KB, text/plain)
2002-08-01 17:47 EDT, Marc Deslauriers
no flags Details
Here is the xfree log (23.68 KB, text/plain)
2002-08-01 17:47 EDT, Marc Deslauriers
no flags Details

  None (edit)
Description Marc Deslauriers 2002-07-30 23:13:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
After installing limbo 7.3.93, firstboot flickers the screen a few times and
fails to appear. X starts up and GDM then appears.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Limbo
2.Reboot
3.Watch firstboot fail to come up
	

Actual Results:  Screen flickers, and X starts up without firstboot

Expected Results:  Firstboot should appear before X starts

Additional info:

I seem to remember firstboot working correctly with the first limo beta.
Comment 1 Brent Fox 2002-08-01 12:23:25 EDT
Can you attach your /var/log/messages file?
Comment 2 Marc Deslauriers 2002-08-01 17:47:21 EDT
Created attachment 68345 [details]
Another try at the /var/log/messages file
Comment 3 Marc Deslauriers 2002-08-01 17:47:51 EDT
Created attachment 68346 [details]
Here is the xfree log
Comment 4 Peter van Egdom 2002-08-03 14:05:42 EDT
Symtoms of this bug look like bug # 68743.

Jul 30 22:29:53 linux firstboot: Window manager error: Unable to open X display :1
Jul 30 22:29:53 linux firstboot: 
Jul 30 22:29:53 linux firstboot: ** (--display=:1:816): WARNING **:
CORBA_ORB_destroy: ORB still has 2 refs.
Jul 30 22:29:53 linux firstboot: in start_existing_X
Jul 30 22:29:53 linux firstboot: Traceback (most recent call last):
Jul 30 22:29:53 linux firstboot:   File "/usr/sbin/firstboot", line 120, in ?
Jul 30 22:29:53 linux firstboot:     firstbootWindow.firstbootWindow(wm_pid,
doReconfig, doDebug)
Jul 30 22:29:53 linux firstboot: AttributeError: 'module' object has no
attribute 'firstbootWindow'
Comment 5 Warren Togami 2002-08-12 07:35:57 EDT
I did several fresh installs (all custom) of Limbo2 on several systems in the
past 2 days.  On my laptop firstboot always fails to run with this exact problem
of trying to connect to display :1.  It failed perhaps 5 other times on some of
my desktops, and I have seen it run properly only once.

Tested Rawhide firstboot-0.9.9-1 on all these systems too.  Still same problem.

BTW, can firstboot please be removed from init 3?
Comment 6 Brent Fox 2002-08-13 21:01:55 EDT
I believe that this problem has been fixed with firstboot-0.9.9-7 or later.  In
addition, I have set firstboot to only run in runlevel 5.

QA, please verify.  This is the race condition bug that we have seen on a few
machines.  I have been unable to reproduce it after the fix I added yesterday.
Comment 7 Jay Turner 2002-08-20 09:20:19 EDT
I'm no longer seeing this race on any of the machines that I'm testing with. 
Closing as fixed in firstboot-0.9.9-13.

Note You need to log in before you can comment on or make changes to this bug.