This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 702205 - Multibyte characters in a po cannot be processed by Zanata properly
Multibyte characters in a po cannot be processed by Zanata properly
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
1.3-alpha-1
All Linux
medium Severity medium
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-04 23:59 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-05 03:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kenichi Takemura 2011-05-04 23:59:25 EDT
Description of problem:

Accidentally I was trying to import a pot file that contains a single multibyte character and mvn zanata:publican-push produces Embedded error: operation returned 500 (Internal Server Error).

As a client user this looks like a zanata system error but in fact from the server.log zanata cannot deal with multibyte character.

This should be rectified in either way

- More appropriate error message in order for user to fix the book.
- Zanata supports multibyte characters

Caused by: java.sql.SQLException: Incorrect string value: '\xE2\x88\x97, B...' for column 'content' at row 1
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1055)

The msgstr of the po looks

msgid "Xen and the Art of Virtualization, Paul Barham∗, Boris Dragovic. University of Cambridge SOSP'03 paper"
msgstr ""

$ xxd RHEL_5-7/ja-JP/Chapters/Test_design/Block_device_model.po | grep e288
0002e80: 2050 6175 6c20 4261 7268 616d e288 972c   Paul Barham...,

'∗' is a multibyte character.

Version-Release number of selected component (if applicable):
Zanata version 1.3-alpha-1 (20110330-1649)

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
import ends up with internal error

Expected results:
- More appropriate error message in order for user to fix the book.
- Zanata supports multibyte characters

Additional info:
Comment 1 Sean Flanigan 2011-05-05 01:36:31 EDT
Was this the same system which was using a latin1 database?
Comment 2 Kenichi Takemura 2011-05-05 03:23:09 EDT
Tested again. My mistake. Sorry for disturbing.

Note You need to log in before you can comment on or make changes to this bug.