Bug 70227 - rpm 4.0.3 complains about invalid group, --force fails to uncompress
rpm 4.0.3 complains about invalid group, --force fails to uncompress
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 01:43 EDT by Keith Owens
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 17:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Owens 2002-07-31 01:43:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.18-xfs i586)

Description of problem:
First problem: rpmbuild 4.0.3 complains if there is no /etc/group entry for the
owner of a tarball.

Second problem: rpmbuild --force bypasses the group check.  Alas it also skips
the decompress of the tarball.

Version-Release number of selected component (if applicable):
4.0.3

How reproducible:
Always

Steps to Reproduce:
1. Create a user with a group that is not defined in /etc/group
2. As that user, rpmbuild --rebuild ...src.rpm
3. second problem, rpmbuild --force --rebuild ...src.rpm
	

Actual Results:

2.  Installing /home/kaos/modutils-2.4.19-1.src.rpm
error: Bad owner/group: /build/kaos/redhat/SOURCES/modutils-2.4.19.tar.gz

3.  Installing /home/kaos/modutils-2.4.19-1.src.rpm
Executing(%prep): /bin/sh -e /build/kaos/rpm-tmp.37351
+ umask 022
+ cd /build/kaos/redhat/BUILD
+ cd /build/kaos/redhat/BUILD
+ rm -rf modutils-2.4.19
+ tar -xvvf /build/kaos/redhat/SOURCES/modutils-2.4.19.tar.gz
tar: This does not look like a tar archive
tar: Skipping to next header


Expected Results:
Installing /home/kaos/modutils-2.4.19-1.src.rpm
Executing(%prep): /bin/sh -e /build/kaos/rpm-tmp.42907
+ umask 022
+ cd /build/kaos/redhat/BUILD
+ cd /build/kaos/redhat/BUILD
+ rm -rf modutils-2.4.19
+ /bin/gzip -dc /build/kaos/redhat/SOURCES/modutils-2.4.19.tar.gz
+ tar -xvvf -


Additional info:
Comment 1 Jeff Johnson 2002-07-31 11:24:24 EDT
Yup, this is the way rpmbuild has always behaved,
This is broken (by design, not mine) IMHO, but
the behavior is intrinsically coupled to the
concept of "reproducible builds using rpm" and
can't be changed without a whole lot of tedious
discussion to redefine what is meant by "reproducible".

I'm gonna close this WONTFIX even though I happen to
agree with you.
Comment 2 Keith Owens 2002-07-31 17:51:46 EDT
I can understand WONTFIX for the invalid group.  What about --force skipping the
uncompress step.  That makes no sense at all.
Comment 3 Jeff Johnson 2002-08-02 10:31:19 EDT
Same answer as before.

Note You need to log in before you can comment on or make changes to this bug.