Bug 70234 - hwbrowser crashes on start
hwbrowser crashes on start
Status: CLOSED DUPLICATE of bug 67957
Product: Red Hat Public Beta
Classification: Retired
Component: hwbrowser (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 03:03 EDT by Thomas M Steenholdt
Modified: 2013-04-02 00:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 19:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-07-31 03:03:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
When launching the hwbrowser, i get to enter root pw and the "searching for hw"
window comes up... The the main window flashes upon the screen and disappears

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start hwbrowser
2.
3.
	

Actual Results:  Never starts correctly

Expected Results:  Should statr correctly

Additional info:

This is the output from the hwbrowser...
-----------------------------------------------------------
(DeviceList.py:1888): Gdk-WARNING **: locale not supported by Xlib

(DeviceList.py:1888): Gdk-WARNING **: can not set locale modifiers

(DeviceList.py:1887): Gdk-WARNING **: locale not supported by Xlib

(DeviceList.py:1887): Gdk-WARNING **: can not set locale modifiers

(DeviceList.py:1887): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1887): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1887): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1887): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 163, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 156, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 485, in initialize
    populate (tree_view, disks, graph)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 379, in populate
    raise RuntimeError, ("can't handle more than "
RuntimeError: can't handle more than one extended partition per disk

** (DeviceList.py:1887): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.



Since the output mentions disk partitions i thought i'd gif you some disk
information as well:
---------------------------------------------------------
sfdisk -l /dev/hda

Disk /dev/hda: 2434 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1   *      0+    636     637-   5116671    7  HPFS/NTFS
/dev/hda2        637    1401     765    6144862+  83  Linux
/dev/hda3       1402    1466      65     522112+  82  Linux swap
/dev/hda4       1467    2433     967    7767427+   f  Win95 Ext'd (LBA)
/dev/hda5       2107+   2433     327-   2626596    b  Win95 FAT32
/dev/hda6       1467+   2106     640-   5140737   83  Linux
Comment 1 Fabricio C Zuardi 2002-08-08 19:07:33 EDT
dupe of bug 67957 ?
Comment 2 Jay Turner 2002-08-13 21:03:33 EDT

*** This bug has been marked as a duplicate of 67957 ***
Comment 3 David Lawrence 2006-04-24 15:17:26 EDT
Adding to blocker bug 185486 and to IBM confidential group.
Comment 4 David Lawrence 2006-04-24 15:31:18 EDT
OOps. Sorry for the mistake. I searched by the wrong list and mistakenly made
these changes. Sorry for the spam. Removing from blocker bug 185486 and to IBM
confidential group.
Comment 5 David Lawrence 2006-04-24 15:48:02 EDT
The last changes to these bugs were mistakenly made. Removing incorrect blocker
bug and confidential group.

Note You need to log in before you can comment on or make changes to this bug.