Bug 70239 - OpenOffice 1.0.1-2 does not build on RH73
OpenOffice 1.0.1-2 does not build on RH73
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 71176 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 05:25 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 16:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The error messages appearing during the rebuild of openoffice (deleted)
2002-07-31 05:26 EDT, Need Real Name
no flags Details
The error messages appearing during the rebuild of openoffice (deleted)
2002-07-31 05:27 EDT, Need Real Name
no flags Details
The error messages appearing during the rebuild of openoffice (deleted)
2002-07-31 05:27 EDT, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2002-07-31 05:25:42 EDT
Description of Problem:
OpenOffice 1.0.1-2 does not build on RH73. I downloaded the .src.rpm from
Rawhide. I changed the gcc3.1 flags from 1 to 0 (to use gcc 2.96) and my machine
has all the patches from RedHat applied.

Version-Release number of selected component (if applicable):
OpenOffice 1.0.1-2
gcc-2.96-102

How Reproducible:


Steps to Reproduce:
1. rpm -Uvh openoffice-1.0.1-2.src.rpm 
2. change the gcc3.1 flags from 1 to 0 in the .spec file
3. rpm -ba openoffice-1.0.spec

Actual Results:
See attachment file.

Expected Results:
To get the package built...
Comment 1 Need Real Name 2002-07-31 06:30:05 EDT
It seems like the system did not take my attachment file.
Here is its content:


------------------------------
Making: ../../../unxlngi3.pro/slo/hashtable.obj
gcc -nostdinc -c -I. -I. -I../inc -I../../../inc -I../../../unx/inc
-I../../../unxlngi3.pro/inc -I. -I/usr/src/redhat/BUILD/oo_1.0.1_src/sal/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/vos/inc  -I.
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc/dont_use_stl
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc/external
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solenv/unxlngi3/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solenv/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/res
-I/usr/src/redhat/BUILD/oo_1.0.1_src/fakejdk/include
-I/usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/dont_use_stlport
-I/usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/include/dont_use_stlport
-I/usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/include/dont_use_stlport
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solenv/inc/Xp31 -I/usr/X11R6/include    
-I. -I../../../res -I. -O2 -march=i386 -mcpu=i686   -I../xmltok -O2 -march=i386
-mcpu=i686 -pipe  -fpic -DLINUX -DUNX -DVCL -DGCC -DC295 -DINTEL -DCVER=C295
-D_USE_NAMESPACE -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR
-D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -D__DMAKE -DUNIX -DCPPU_ENV=gcc2
-DSUPD=641 -DBUILD=7663 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOPTIMIZE
-DEXCEPTIONS_OFF -DCUI -DSOLAR_JAVA -DSRC641 -DBOOTSTRAPPER -DSHAREDLIB -D_DLL_
 -DMULTITHREAD -w -o ../../../unxlngi3.pro/slo/hashtable.o hashtable.c
In file included from hashtable.c:31:
../xmltok/xmldef.h:31:20: string.h: No such file or directory
../xmltok/xmldef.h:47:20: stdlib.h: No such file or directory
In file included from hashtable.c:39:
hashtable.h:32:20: stddef.h: No such file or directory
In file included from hashtable.c:39:
hashtable.h:54: parse error before `size_t'
hashtable.h:56: parse error before `usedLim'
hashtable.h:59: parse error before `*'
hashtable.h:60: parse error before `*'
hashtable.h:61: parse error before `*'
hashtable.h:68: parse error before `*'
hashtable.c:61: parse error before `*'
hashtable.c: In function `lookup':
hashtable.c:63: `size_t' undeclared (first use in this function)
hashtable.c:63: (Each undeclared identifier is reported only once
hashtable.c:63: for each function it appears in.)
hashtable.c:63: parse error before `i'
hashtable.c:64: `table' undeclared (first use in this function)
hashtable.c:65: `createSize' undeclared (first use in this function)
hashtable.c:72: `i' undeclared (first use in this function)
hashtable.c:72: `name' undeclared (first use in this function)
hashtable.c:86: parse error before `newSize'
hashtable.c:87: `newSize' undeclared (first use in this function)
hashtable.c:92: parse error before `j'
hashtable.c:93: `j' undeclared (first use in this function)
hashtable.c: At top level:
hashtable.c:117: parse error before `*'
hashtable.c: In function `hashTableDestroy':
hashtable.c:119: `size_t' undeclared (first use in this function)
hashtable.c:119: parse error before `i'
hashtable.c:120: `i' undeclared (first use in this function)
hashtable.c:120: `table' undeclared (first use in this function)
hashtable.c: At top level:
hashtable.c:128: parse error before `*'
hashtable.c: In function `hashTableInit':
hashtable.c:130: `p' undeclared (first use in this function)
hashtable.c: At top level:
hashtable.c:136: parse error before `*'
hashtable.c: In function `hashTableIterInit':
hashtable.c:138: `iter' undeclared (first use in this function)
hashtable.c:138: `table' undeclared (first use in this function)
dmake:  Error code 1, while making '../../../unxlngi3.pro/slo/hashtable.obj'
---* TG_SLO.MK *---

ERROR: Error 65280 occurred while making
/usr/src/redhat/BUILD/oo_1.0.1_src/external/expat/rtufiles/xmlparse
+ '[' 1 -gt 4 ']'
+ RPM_BUILD_NCPUS=1
+ DMAKE_P=
+ '[' 1 -gt 1 ']'
++ i=0
++ '[' -f /tmp/.X0-lock ']'
++ i=1
++ '[' -f /tmp/.X1-lock ']'
++ i=2
++ '[' -f /tmp/.X2-lock ']'
++ echo 2
+ XDISPLAY=2
+ /bin/csh -c 'setenv DISPLAY :2; source LinuxIntelEnv.Set; cd transex3/prj;
../../solenv/bin/build.pl -from freetype product=full '
+ /usr/X11R6/bin/Xvfb -ac :2
build -- version: 1.41

=============
Building project stlport
=============
/usr/src/redhat/BUILD/oo_1.0.1_src/stlport
mkout -- version: 1.3
         An already available installatin of STLport has been chosen in the
configure process.
         Therefore the version provided here does not need to be built in addition.
cp -f /usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/lib/*stlport*.so
./unxlngi3.pro/lib
deliver -- version: 1.17.4.1
COPY: build.lst ->
/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc/stlport/build.lst
COPY: ../unxlngi3.pro/lib/libstlport_gcc.so ->
/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/lib/libstlport_gcc.so
COPY: ../unxlngi3.pro/lib/libstlport_gcc_stldebug.so ->
/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/lib/libstlport_gcc_stldebug.so
Statistics:
Files copied: 3
Files unchanged/not matching: 1

=============
Building project soltools
=============
/usr/src/redhat/BUILD/oo_1.0.1_src/soltools/mkdepend
mkout -- version: 1.3
------------------------------
Making: ../unxlngi3.pro/misc/make_makedepend.dpc
NOT-Making: Depend-Lists
------------------------------
Making: ../unxlngi3.pro/obj/cppsetup.obj
gcc -nostdinc -c -I. -I. -I../inc -I../inc -I../unx/inc -I../unxlngi3.pro/inc
-I.
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc/dont_use_stl
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc/external
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solver/641/unxlngi3.pro/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solenv/unxlngi3/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solenv/inc
-I/usr/src/redhat/BUILD/oo_1.0.1_src/res
-I/usr/src/redhat/BUILD/oo_1.0.1_src/fakejdk/include
-I/usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/dont_use_stlport
-I/usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/include/dont_use_stlport
-I/usr/src/redhat/BUILD/oo_1.0.1_src/STLport-4.5.3/include/dont_use_stlport
-I/usr/src/redhat/BUILD/oo_1.0.1_src/solenv/inc/Xp31 -I/usr/X11R6/include    
-I. -I../res -I. -O2 -march=i386 -mcpu=i686   -O2 -march=i386 -mcpu=i686 -pipe 
 -DLINUX -DUNX -DVCL -DGCC -DC295 -DINTEL -DCVER=C295 -D_USE_NAMESPACE -DGLIBC=2
-DX86 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1
-DSTLPORT_VERSION=400 -D__DMAKE -DUNIX -DCPPU_ENV=gcc2 -DSUPD=641 -DBUILD=7663
-DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOPTIMIZE -DEXCEPTIONS_OFF -DCUI -DSOLAR_JAVA
-DSRC641  -DNO_X11 -DXP_PC -DHW_THREADS -DINCLUDEDIR=\".\" -DSINGLETHREAD  -w -o
../unxlngi3.pro/obj/cppsetup.o cppsetup.c
In file included from cppsetup.c:29:
def.h:39:19: stdio.h: No such file or directory
def.h:40:20: stdlib.h: No such file or directory
def.h:42:19: ctype.h: No such file or directory
def.h:48:23: sys/types.h: No such file or directory
def.h:49:19: fcntl.h: No such file or directory
def.h:50:22: sys/stat.h: No such file or directory
def.h:138:20: stdlib.h: No such file or directory
In file included from cppsetup.c:127:
ifparser.h:58:19: stdio.h: No such file or directory
cppsetup.c: In function `_my_if_errors':
cppsetup.c:160: `NULL' undeclared (first use in this function)
cppsetup.c:160: (Each undeclared identifier is reported only once
cppsetup.c:160: for each function it appears in.)
cppsetup.c: In function `_lookup_variable':
cppsetup.c:180: `NULL' undeclared (first use in this function)
dmake:  Error code 1, while making '../unxlngi3.pro/obj/cppsetup.obj'
---* TG_SLO.MK *---

ERROR: Error 65280 occurred while making
/usr/src/redhat/BUILD/oo_1.0.1_src/soltools/mkdepend
error: Bad exit status from /var/tmp/rpm-tmp.91035 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.91035 (%build)
Comment 2 Sammy 2002-08-01 10:29:23 EDT
Ditto from here...I get the identical error BUT before that I had another error 
complaining that GPC was not found. For that I had to comment out the 
lines in configure.in for gcc296. 
 
I am using RH for a long time and really dissapointed with the application 
updates to 7.3 - Bero could you please make kde-3.0.2 for 7.3. We are the 
only distribution that does not have this available (not the CVS).
Comment 3 Bernhard Rosenkraenzer 2002-08-12 09:23:16 EDT
*** Bug 71176 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.