Bug 70245 - The /sbin/if{up,down}-local belong below /etc
Summary: The /sbin/if{up,down}-local belong below /etc
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-31 10:38 UTC by Jos Vos
Modified: 2014-03-17 02:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 20:11:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2002-07-31 10:38:07 UTC
The ifup-post script calls /sbin/ifup-local, if it exists, and a similar thing
happens for ifdown-local. Because these are meant (I assume) as
user-configurable scripts, they should be in /etc, probably in
/etc/sysconfig/network-scripts.

If RH wants to keep the compatibility with previous releases, you can just add
symlinks /sbin/ifup-local -> /etc/sysconfig/network-scripts/ifup-local and
/sbin/ifdown-local -> /etc/sysconfig/network-scripts/ifdown-local and everything
should work fine in either case.

Comment 1 Jos Vos 2002-08-01 16:40:49 UTC
This also applies to the if{up,down}-pre-local scripts.

Comment 2 Bill Nottingham 2005-09-29 20:11:13 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Realistically, changing this now would require a) adding symlinks which b) would
overwrite existing scripts. Not sure it's worth the effort.


Note You need to log in before you can comment on or make changes to this bug.