Bug 702553 - package_cleanup wants to remove 1.8G of (core?) packages
package_cleanup wants to remove 1.8G of (core?) packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-06 02:32 EDT by Jon Masters
Modified: 2014-01-21 18:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-06 03:00:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Masters 2011-05-06 02:32:47 EDT
Description of problem:

So I was getting few warnings of duplicate packages when cleaning up a system I'd upgraded from older rawhide to 15. But what I wasn't expecting was:

Transaction Summary
================================================================================
Remove     1060 Package(s)

Installed size: 1.8 G

Version-Release number of selected component (if applicable):

Name        : yum-utils
Version     : 1.1.30
Release     : 2.fc15

It wanted to remove about half the packages on the system, including a lot of core stuff. The result was a mess, and only aborted after I noticed I couldn't ssh into the machine any more. This was the first time I've tried using this command to clean up dupes, and it will be the last time I use it also.

Jon.
Comment 1 Jon Masters 2011-05-06 03:00:44 EDT
I retract that report. Something killed my SSH at the same time I ran this so I pre-maturely blamed package_cleanup. I think it's working just fine. As for the server, I think it needs to be re-installed at this point as it's just too tricky to really go from an older rawhide to F15.

Note You need to log in before you can comment on or make changes to this bug.