Bug 702698 - xscreensaver 5.13-1 turns off monitor after screen blanking time rather than display-off time.
Summary: xscreensaver 5.13-1 turns off monitor after screen blanking time rather than ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver
Version: 14
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-06 15:58 UTC by Frank Samuelson
Modified: 2011-05-25 02:24 UTC (History)
1 user (show)

Fixed In Version: xscreensaver-5.13-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-13 23:13:17 UTC


Attachments (Terms of Use)

Description Frank Samuelson 2011-05-06 15:58:23 UTC
Description of problem:

xscreensaver 5.13-1 turns off my monitor after the amount of time set in the screen blanking setting time rather than display-off time setting.

Version-Release number of selected component (if applicable): 5.13-1


How reproducible: Always
reverting back to xscreensaver-base-5.12-6.fc14.i686 fixes the problem.

Steps to Reproduce:
1. run xscreensaver
2. set "Blank After" time to 1 minute with xscreensaver-demo
3. set the display "Off After" time to 30 minutes
  
Actual results:
Display powers off after 1 minute

Expected results:
Display powers off after 30 minutes.  This happens with xscreensaver-5.12-6.fc14.i686, but not xscreensaver-5.13-1.fc14.i686

Additional info:

Comment 1 Mamoru TASAKA 2011-05-06 17:27:43 UTC
Does not seem to be reproducible with me (although I am using F-15). Would you do the following? Thank you.

- Attach /etc/X11/xorg.conf (if any), and /var/log/Xorg.0.log
- Attach ~/.xscreensaver
- Once kill xscreensaver with
  $ xscreensaver-command -exit
  , and attach the output of
  $ xscreensaver -debug

Comment 2 Mamoru TASAKA 2011-05-10 15:33:26 UTC
Ah, now I checked 5.13 code (due to another bug), and if you are using "Blank screen only", you will see this behavior, i.e. if you are using "Blank screen only", xscreensaver 5.13 now set the power of the monitor off regardless of DPMS settings.

It seems that this is the upstream's intentional change, however it seems that this new behavior are causing confusion on you. Perhaps once I will revert this new "behavior".

Comment 3 Fedora Update System 2011-05-10 17:12:50 UTC
xscreensaver-5.13-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xscreensaver-5.13-2.fc15

Comment 4 Fedora Update System 2011-05-10 17:13:06 UTC
xscreensaver-5.13-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xscreensaver-5.13-2.fc14

Comment 5 Fedora Update System 2011-05-10 21:16:58 UTC
Package xscreensaver-5.13-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xscreensaver-5.13-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xscreensaver-5.13-2.fc14
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-05-13 23:13:08 UTC
xscreensaver-5.13-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-05-16 03:28:17 UTC
xscreensaver-5.13-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xscreensaver-5.13-3.fc15

Comment 8 Fedora Update System 2011-05-25 02:24:31 UTC
xscreensaver-5.13-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.