Bug 702749 - gdm-simple-greeter goes up to 100% CPU after timed login
gdm-simple-greeter goes up to 100% CPU after timed login
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-05-06 16:06 EDT by Christoph Wickert
Modified: 2015-01-14 18:26 EST (History)
3 users (show)

See Also:
Fixed In Version: gdm-3.0.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 00:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-05-06 16:06:46 EDT
Description of problem:
Login is not possible on F15 Xfce Spin TC1. After the countdown for the timed login is over, nothing happens and gdm-simple-greater goes up to 100% CPU.

Version-Release number of selected component (if applicable):
gdm-3.0.0-2.fc15

How reproducible:
always

Steps to Reproduce:
1. Boot F15 Xfce TC1
2. Wait until the countdown for automatic login has passed

Actual results:
No login but gdm-simple-greater goes up to 100% CPU

Expected results:
gdm should log into Xfce

Additional info:
Canceling the timeout and clicking on "Livesystem User" starts the Xfce session without problems.
Comment 1 Ray Strode [halfline] 2011-05-06 16:16:28 EDT
may be a dupe of bug 690873
Comment 2 Fedora Update System 2011-05-06 16:33:37 EDT
gdm-3.0.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gdm-3.0.0-3.fc15
Comment 3 Christoph Wickert 2011-05-06 18:26:30 EDT
(In reply to comment #1)
> may be a dupe of bug 690873

I don't think this is the same bug. Mine only happens with timed login and the other bug does not mention that at all

I have switched the Xfce Spin to auto-login and now things are fine for me. Removing F15Blocker-xfce and lowering severity.
Comment 4 Christoph Wickert 2011-05-06 18:28:30 EDT
Interesting enough, I just noticed that TC1 Xfce *does* start an Xfce session, it just takes ages because gdm-simple-greater is eating up all CPU.
Comment 5 Christoph Wickert 2011-05-06 18:45:46 EDT
Ok, took TC1 again, updated to 3.0.0-3 and restarted prefdm.service. Timed login now works fine and without the high CPU usage. Thanks a lot Ray!
Comment 6 Fedora Update System 2011-05-07 11:09:10 EDT
Package gdm-3.0.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.0.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gdm-3.0.0-3.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-05-09 00:05:24 EDT
gdm-3.0.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.