Bug 702775 - Constant load on F15 machine with no processes using CPU
Constant load on F15 machine with no processes using CPU
Status: CLOSED DUPLICATE of bug 703511
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-06 22:45 EDT by Jeff Sheltren
Modified: 2011-05-18 14:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-18 14:09:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Sheltren 2011-05-06 22:45:18 EDT
System has a constant load of ~1.00 with no intensive processes running.  This has been a consistent issue on this machine since the F15 alpha.  Currently running kernel version 2.6.38.5-22.fc15.x86_64.

top shows no process using much CPU, nor any notable I/O wait.

This is immediate after boot and load never goes down.

Tried checking if this was perhaps some process running on and off fast enough that it wasn't visible in top.  Running ps repeatedly didn't reveal any process, and the pids of the ps processes incremented in sequence demonstrating there were no other processes starting and stopping between ps runs.

Hardware is a Lenovo Thinkpad with an Intel i7 CPU.
Comment 1 Jeff Sheltren 2011-05-14 16:26:31 EDT
Did a fresh install of F15 and latest updates-testing packages on the same hardware and after the first reboot this problem persists.

2.6.38.5-24.fc15.x86_64
Comment 2 Jeff Sheltren 2011-05-16 10:49:15 EDT
Idle load issue persists with latest 2.6.38.6-26.rc1.fc15.x86_64 kernel, even when booted into single user mode.
Comment 3 Jeff Sheltren 2011-05-16 16:23:59 EDT
perf top shows 'drm_addmap_core' hovering around 20-30% of samples.  Is that meaningful?
Comment 4 Chuck Ebbert 2011-05-17 09:25:33 EDT
It's probably just a process stuck in uninterruptible sleep. The ps command should be able to show that. If it's not causing CPU load then it's not really harmful though.
Comment 5 Jeff Sheltren 2011-05-17 11:52:03 EDT
(In reply to comment #4)
> It's probably just a process stuck in uninterruptible sleep. The ps command
> should be able to show that. If it's not causing CPU load then it's not really
> harmful though.

ps ax shows:
 627 ?        D      0:00 [ips-monitor]

As the only process in that state.
Comment 6 Chuck Ebbert 2011-05-18 14:09:41 EDT

*** This bug has been marked as a duplicate of bug 703511 ***
Comment 7 Jeff Sheltren 2011-05-18 14:55:28 EDT
(In reply to comment #6)
> 
> *** This bug has been marked as a duplicate of bug 703511 ***

Chuck, thanks for your help on this!

Note You need to log in before you can comment on or make changes to this bug.