Bug 702784 - kpackagekit won't do updates, yum clean then yum update works
kpackagekit won't do updates, yum clean then yum update works
Status: CLOSED DUPLICATE of bug 702501
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-07 02:31 EDT by gene smith
Modified: 2011-05-09 21:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-07 16:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gene smith 2011-05-07 02:31:52 EDT
Description of problem:

F14 system behind firewall and uses proxy to access yum repositories. Usually don't see update notification in tray unless I do a "yum clean all" after the previous update. Also kpackagekit will not do updates when commanded due to "waiting for other application" (which may be zombie yumBackend.py that I usually see, not sure). Yum update always works but sometimes have to do yum clean all before yum update sees anything.

This was a fresh install of F14 on system that uses proxy access. Have another system that I upgraded from F13 to F14 that always works fine doing automatic updates or update requests from kpackagekit and directly from yum that never requires a yum clean. However, this other system uses direct connect to internet with no proxy.

Version-Release number of selected component (if applicable):

Fully updated (no testing or rawhide) f14 kde 4.6.2 system, x86_64


How reproducible:


Steps to Reproduce:
1. On system using proxy, don't see updates in tray after many days.
2. Run kpackagekit and check for updates
3. Seem to wait for "other application" too long. Exit kpackagekit using by 
closing window with "x" Also, sometimes it claims it need authentication but there is no prompt for authentication.
4. Run sudo yum update and usually finds update but sometimes have to do 
"sudo yum clean all" first.
5. After yum update, if do yum clean I see new updates OK in tray and can update by clicking on icon there when new updates available. If I don't do yum clean, the problem seems to arise.
  
Actual results:
Only get updates with yum update not with kpackagekit.


Expected results:
Should be able to get updates automatically using tray icon and never need to run yum update or do yum clean. Works as expected on f14 system with direct connect to internet, bad on other system using proxy connection to yum repositories.


Additional info:
Main difference between system that works OK and on that does not is OK system uses direct connect and system that has this problem uses proxy connect.
Comment 1 Rex Dieter 2011-05-07 16:13:54 EDT

*** This bug has been marked as a duplicate of bug 702501 ***
Comment 2 gene smith 2011-05-09 21:35:22 EDT
Don't think what I see in Bug 702501 (now also closed) is the same as this. For one thing I am using pure f14 with kde 4.6.2 (only f14 updates repo enabled) and problem has been happening ever since I installed in on the system in early April, way before the update of May 5th. Also, it only occurs on the system that uses proxy and not on another system that is direct connect. Finally, I don't see an "internal system error" message of any sort. 

Checked kde buglist for kpackagekit and proxy and only see old apt/debian
related problems all closed or fixed.

Note You need to log in before you can comment on or make changes to this bug.