This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 70323 - redhat-config-packages does not work
redhat-config-packages does not work
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-packages (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 12:39 EDT by Jeronimo Alaminos
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 12:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeronimo Alaminos 2002-07-31 12:39:09 EDT
Description of Problem:
As i said redhat-config-packages does not work. It appears the main window and a
progress bar and then 

TTraceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 96, in ?
    hdlist = im.readHeaders()
  File "/usr/share/redhat-config-packages/method.py", line 124, in readHeaders
    return hdrlist.HeaderListFromFile(self.baseDir + "/hdlist")
  File "/usr/share/redhat-config-packages/hdrlist.py", line 63, in __init__
    hdlist = rpm.readHeaderListFromFile(path)
rpm404.error: (2, 'No existe el fichero o el directorio')
raceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 96, in ?
    hdlist = im.readHeaders()
  File "/usr/share/redhat-config-packages/method.py", line 124, in readHeaders
    return hdrlist.HeaderListFromFile(self.baseDir + "/hdlist")
  File "/usr/share/redhat-config-packages/hdrlist.py", line 63, in __init__
    hdlist = rpm.readHeaderListFromFile(path)
rpm404.error: (2, 'No existe el fichero o el directorio')

Also noted that in the file /usr/share/redhat-config-packages/config.py
appears
TMPTREEREPLACE='/mnt/redhat/test/Milan-re0723.nightly/i386/i386/'
and i suppose it should be something different.

Thank you.




Version-Release number of selected component (if applicable):
redhat-config-packages and rpm from rawhide-20020731


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jeremy Katz 2002-07-31 20:07:08 EDT
Right now, it only works if you've done an actual install and thus gotten the
comps.rpm package installed.  Due to be changed, but a few other things are
higher priority to get done first

Note You need to log in before you can comment on or make changes to this bug.